Search found 48 matches

by treble
Mon Jun 03, 2024 12:56 pm America/New_York
Forum: Home
Question: OCCSW binary compatibility in Linux
Replies: 2

Re: OCCSW binary compatibility in Linux

Me too :-). Our cluster is running CenOS 7, it's old, but they are not planning to upgrade soon...

I tried to compile from scratch but that failed. See some of my earlier posts.
by treble
Tue Feb 27, 2024 1:06 pm America/New_York
Forum: Home
Question: seadas install: java: Bad CPU type in executable
Replies: 1

seadas install: java: Bad CPU type in executable

I am helping someone install SeaDAS on a MacBook M2. We are getting the following error: bash-3.2$ sh seadas_8.4.1_mac_installer.sh Verifying archive integrity... 100% MD5 checksums are OK. All good. Uncompressing SeaDAS by Ocean Ecology Lab 100% ./start-install-script.sh: line 2: jdk-11.0.19+7/Cont...
by treble
Mon Feb 12, 2024 7:04 pm America/New_York
Forum: Home
Question: Cannot install SeaDAS 8.4.1 with the Linux installer script
Replies: 3

Re: Cannot install SeaDAS 8.4.1 with the Linux installer script

In spite of that error (ler: command not found), SeaDAS still installed fine for me on CentOS 7. [xxxx:/tmp 1003]$ sh seadas_8.4.1_linux64_installer.sh Verifying archive integrity... 100% MD5 checksums are OK. All good. Uncompressing SeaDAS by Ocean Ecology Lab 100% Command line arguments: seadas_8....
by treble
Fri Feb 09, 2024 1:41 pm America/New_York
Forum: Home
Question: gpt WriteImage - where did it go?
Replies: 1

gpt WriteImage - where did it go?

Starting with SeaDAS 8 the gpt WriteImage operator has disappeared. I checked with the SNAP people on the STEP forum and they said it was created by the 'SeaDAS guys'. Could it be brought back to gpt? I could still use the 7.5.3 version, with some modifications of the gpt scripts since java has chan...
by treble
Tue Jan 16, 2024 4:26 pm America/New_York
Forum: Home
Question: GLIBC problem is back... [CentOS 7 RIP]
Replies: 4

Re: GLIBC problem is back... [CentOS 7 RIP]

Thanks, it fails on linking the jpeg libraries. See last pertinent part where it fails below. Earlier on I see that it doesn't use the compiled jpeg libraries but the system ones... Not sure how to tell cmake or whatever to use the one in the SeaDAS directory (it is located in $OCSSWROOT/opt/lib/lib...
by treble
Fri Jan 12, 2024 12:45 pm America/New_York
Forum: Home
Question: GLIBC problem is back... [CentOS 7 RIP]
Replies: 4

Re: GLIBC problem is back...

Ah, that is unfortunate. Especially since the high performance computer cluster at our university is running CentOS 7 as well... I will have to build from source in the future then I am afraid. I tried it now as well (following the directions for CentOS on the website) but it failed at compiling hdf...
by treble
Tue Jan 09, 2024 7:17 pm America/New_York
Forum: Home
Question: GLIBC problem is back... [CentOS 7 RIP]
Replies: 4

GLIBC problem is back... [CentOS 7 RIP]

Using SeaDAS 8.4.1 with the latest tag (V2023.3) gives me the GLIBC error again on CentOS 7. See this old discussion: https://forum.earthdata.nasa.gov/viewtopic.php?t=1419 V2023.2 still works fine...: [/opt/seadas/seadas_8.4.1/ocssw 1016]$ install_ocssw --installed_tag WARNING: --tag is required to ...
by treble
Mon Jan 08, 2024 6:11 pm America/New_York
Forum: Home
Question: update_luts and gpt SeaDAS 8.4.1 on Centos 7
Replies: 3

Re: update_luts and gpt SeaDAS 8.4.1 on Centos 7

Ah, yes, you are completely right. In the GUI it defaulted to an older version/tag. I didn't realize it. Changing it to V2023.3 fixed the update_luts script. Also, regarding java, I just noticed that SeaDAS actually installed java 11 in the SeaDAS install directory ( jdk-11.0.19+7-jre ). So no need ...
by treble
Mon Jan 08, 2024 5:32 pm America/New_York
Forum: Home
Question: update_luts and gpt SeaDAS 8.4.1 on Centos 7
Replies: 3

update_luts and gpt SeaDAS 8.4.1 on Centos 7

I just installed SeaDAS 8.4.1 on Centos 7. I encountered the following 2 issues (more of an FYI): The update_luts is different from the one on my Mac. Version 2.0 vs. 2.1. The Centos (linux64) does not have the option 'all' to update all luts, so you have to go sensor by sensor :( . Plus it is missi...
by treble
Thu Dec 14, 2023 7:21 pm America/New_York
Forum: Home
Question: Cannot install OCSSW Processors with SeaDAS 8.4.1
Replies: 4

Re: Cannot install OCSSW Processors with SeaDAS 8.4.1

Just an FYI that this has been resolved (kind of). SeaDAS was installed as root. I tried to install the Processors as an Admin user that has read/write permissions in the /Applications/SeaDAS folder. Somehow that didn't work. When I reinstalled the software as an Admin user it just worked....