Search found 219 matches

by OB SeaDAS - dshea
Thu Jun 03, 2021 2:00 pm America/New_York
Forum: Questions/Comments
Question: seadas installation problem
Replies: 5

Re: seadas installation problem

This is the problem:
AttributeError: __enter__

This happens if you are using an old version of requests.
What python3 are you using?
What version of requests?

don
by OB SeaDAS - dshea
Thu Jun 03, 2021 8:59 am America/New_York
Forum: Questions/Comments
Question: l2gen Products tab
Replies: 12

Re: l2gen Products tab

Do you have all of the wavelengths checked in the "Wavelength Limiter"?

don
by OB SeaDAS - dshea
Wed Jun 02, 2021 1:08 pm America/New_York
Forum: Questions/Comments
Question: l2gen Products tab
Replies: 12

Re: l2gen Products tab

I forgot to say that latitude and longitude are always output to a L2 file

don
by OB SeaDAS - dshea
Wed Jun 02, 2021 12:59 pm America/New_York
Forum: Questions/Comments
Question: l2gen Products tab
Replies: 12

Re: l2gen Products tab

Strange, I get all of the wavelengths for rhot and I am using Ububtu 20.04 with SeaDAS 8.0.0 and OCSSW V2020.1. If you select the rhot checkbox (not the individual wavelengths), you will note that rhot_nnn is added to the "Selected Products" box at the bottom of the window. That will make ...
by OB SeaDAS - dshea
Thu May 27, 2021 12:21 pm America/New_York
Forum: Questions/Comments
Question: Seadas installation
Replies: 5

Re: Seadas installation

Looks like we forgot to update the requirements for the python version. Python 3.6+ will take care of this problem and it looks like you are running python 3.5

don
by OB SeaDAS - dshea
Thu May 27, 2021 10:01 am America/New_York
Forum: Questions/Comments
Question: Seadas installation
Replies: 5

Re: Seadas installation

Looks like you can not create the file /tmp/manifest.json

Could you give me the output of these commands:

Code: Select all

ls -l /tmp/manifest*
touch /tmp/manifest.json
don
by OB SeaDAS - dshea
Tue Apr 06, 2021 10:24 am America/New_York
Forum: Questions/Comments
Question: OCSSW Processor - MODIS
Replies: 16

Re: OCSSW Processor - MODIS

Python 3.6 or higher will fix the last error. You will need to modify your PATH to point to the new python3.6+ in the ~/.bash_login or ~/.bashrc It is best to NOT run and SeaDAS commands as super user. No need to "sudo" What OS and version is the host What version of Ubuntu What version of...
by OB SeaDAS - dshea
Wed Mar 24, 2021 3:49 pm America/New_York
Forum: Questions/Comments
Question: SeaDAS 8 install_OCSSW problem with python requests
Replies: 40

Re: SeaDAS 8 install_OCSSW problem with python requests

Just to solidify things try this:

ocssw_runner --ocsswroot $OCSSWROOT which python3


if it shows the wrong python3, then all we need to do is fix your PATH

don
by OB SeaDAS - dshea
Wed Mar 24, 2021 1:50 pm America/New_York
Forum: Questions/Comments
Question: SeaDAS 8 install_OCSSW problem with python requests
Replies: 40

Re: SeaDAS 8 install_OCSSW problem with python requests

yes, install_ocssw is special in the SeaDAS GUI. ocssw_runner does not exist yet when install_ocssw runs the first time.

Give me the results of these commands:

which ocssw_runner
ocssw_runner --ocsswroot $OCSSWROOT env


don
by OB SeaDAS - dshea
Wed Mar 24, 2021 11:26 am America/New_York
Forum: Questions/Comments
Question: SeaDAS 8 install_OCSSW problem with python requests
Replies: 40

Re: SeaDAS 8 install_OCSSW problem with python requests

Dirk, "bash -l" does not load ~/.bashrc To get the previous 3 commands to execute correctly, we need to load the .bashrc file from a login file. if you have a ~/.bash_profile file add this code to the file # include .bashrc if it exists if [ -f "$HOME/.bashrc" ]; then . "$HO...