Change default configuration for l2gen not working

Please enter here to ask a question about any NASA Science related topics!
alineval
Posts: 9
Joined: Thu Jun 12, 2008 2:12 pm America/New_York

Re: Change default configuration for l2gen not working

by alineval » Fri Sep 17, 2021 10:16 am America/New_York

When I do l2gen par=l2gen-tmpParFile-test.par on the command line nothing is being showed. I have another seadas running on linux and I could see that this l2gen-tmpParFile*.par file is automatic generated. But when I run seadas on my windows, this file is not being generated. The file that I copied here (l2gen-tmpParFile-test.par) I saved clicking on "save parameters "on the l2gen GUI.

Tags:

OB SeaDAS - xuanyang02
Subject Matter Expert
Subject Matter Expert
Posts: 144
Joined: Tue Feb 09, 2021 5:42 pm America/New_York

Re: Change default configuration for l2gen not working

by OB SeaDAS - xuanyang02 » Mon Sep 20, 2021 11:16 am America/New_York

I am trying to separate the issues. Does the seadas you installed on linux have the same problem you described at the beginning of the post? Or the problem only exists with the seadas you installed on WSL1?

alineval
Posts: 9
Joined: Thu Jun 12, 2008 2:12 pm America/New_York

Re: Change default configuration for l2gen not working

by alineval » Tue Sep 21, 2021 9:32 am America/New_York

The problem only exists with the seadas I installed on WSL1.
I used on linux that is properly working just to compare with the seadas that I'm trying to use on windows.
(I have a linux on work but I'm using windows on my home office)

OB SeaDAS - aynur
Subject Matter Expert
Subject Matter Expert
Posts: 35
Joined: Tue Dec 20, 2011 12:28 pm America/New_York

Re: Change default configuration for l2gen not working

by OB SeaDAS - aynur » Tue Sep 21, 2021 9:56 am America/New_York

Thank you for reporting this issue. We've identified that there is a problem in sending the par file from SeaDAS to the OCSSW server in the client-server mode. The fix will be provided in the next release.

OB SeaDAS - aynur
Subject Matter Expert
Subject Matter Expert
Posts: 35
Joined: Tue Dec 20, 2011 12:28 pm America/New_York

Re: Change default configuration for l2gen not working

by OB SeaDAS - aynur » Tue Sep 21, 2021 12:12 pm America/New_York

alineval wrote: Fri Sep 17, 2021 10:16 am America/New_York When I do l2gen par=l2gen-tmpParFile-test.par on the command line nothing is being showed. I have another seadas running on linux and I could see that this l2gen-tmpParFile*.par file is automatic generated. But when I run seadas on my windows, this file is not being generated. The file that I copied here (l2gen-tmpParFile-test.par) I saved clicking on "save parameters "on the l2gen GUI.
You can execute ocssw programs from the command line in the $OCSSWROOT/bin directory in your wsl. Please make sure that the input file paths are accessible.

alineval
Posts: 9
Joined: Thu Jun 12, 2008 2:12 pm America/New_York

Re: Change default configuration for l2gen not working

by alineval » Tue Sep 21, 2021 2:57 pm America/New_York

Thank you. I'm new on this, could you explain to me how do I submit the process via command console?

OB.DAAC - amscott
User Services
User Services
Posts: 83
Joined: Mon Jun 22, 2020 5:24 pm America/New_York

Re: Change default configuration for l2gen not working

by OB.DAAC - amscott » Tue Sep 21, 2021 3:44 pm America/New_York

I believe the instructions are found here: https://seadas.gsfc.nasa.gov/installers/
--
Alicia

OB SeaDAS - xuanyang02
Subject Matter Expert
Subject Matter Expert
Posts: 144
Joined: Tue Feb 09, 2021 5:42 pm America/New_York

Re: Change default configuration for l2gen not working

by OB SeaDAS - xuanyang02 » Fri Sep 24, 2021 5:34 pm America/New_York

In the $OCSSWROOT/bin directory in your wsl, do

Code: Select all

l2gen par=/mnt/c/Users/aline/OneDrive/Aline/2021_Sargassum/20210901/MODIS/requested_files/l2gen-tmpParFile-test.par

Post Reply