GPT mosaic problem with OLCI L2 files

Please enter here to ask a question about any NASA Science related topics!
Post Reply
tsmoore00
Posts: 14
Joined: Fri Apr 01, 2005 9:31 am America/New_York

GPT mosaic problem with OLCI L2 files

by tsmoore00 » Fri Oct 27, 2017 11:40 am America/New_York

Hi,

I am trying to reproject OLCI level-2 data I processed with Seadas7.4 to a projection that has worked previously with Aqua, MERIS.

I have tried several l2 files, and I keep getting the same error.  Not sure what's happening.  Can you decipher the error message?

The command I am using and response I am getting is:

gpt.command -e bl2map-mosaic_olci.xml -Ssource=$fullFilename -t $outFilename -f netCDF-CF
+ gpt.command -e bl2map-mosaic_olci.xml -Ssource=/Users/tim/Desktop/images/olci/erie/l2/S3A_OL_1_ERR____20170701T145214_20170701T153637_20170702T192226_2663_019_239______LN1_O_NT_002.l2 -t /Users/tim/Desktop/images/olci/erie/remaps//S3A_OL_1_ERR____20170701T145214_20170701T153637_20170702T192226_2663_019_239______LN1_O_NT_002.l2.nc -f netCDF-CF

Error: gov/nasa/gsfc/seadas/bathymetry/operator/BathymetryOp$Spi : Unsupported major.minor version 52.0
if [ $? -ne 0 ]; then
   echo "Geolocation failed for file $fullFilename"
   exit 3
fi
+ '[' 1 -ne 0 ']'
+ echo 'Geolocation failed for file /Users/tim/Desktop/images/olci/erie/l2/S3A_OL_1_ERR____20170701T145214_20170701T153637_20170702T192226_2663_019_239______LN1_O_NT_002.l2'
Geolocation failed for file /Users/tim/Desktop/images/olci/erie/l2/S3A_OL_1_ERR____20170701T145214_20170701T153637_20170702T192226_2663_019_239______LN1_O_NT_002.l2
+ exit 3

I can follow up with the bl2map-mosaic_olci.xml code if needed.

Thanks!
Tim

Tags:

OB SeaDAS - knowles
Subject Matter Expert
Subject Matter Expert
Posts: 221
Joined: Mon Apr 07, 2008 4:40 pm America/New_York

GPT mosaic problem with OLCI L2 files

by OB SeaDAS - knowles » Fri Oct 27, 2017 6:17 pm America/New_York

Hi Tim,

This error message is a problem:
Error: gov/nasa/gsfc/seadas/bathymetry/operator/BathymetryOp$Spi : Unsupported major.minor version 52.0

SeaDAS 7.4 should not be looking for this operator.

I'm not seeing this problem on Linux but I just found a Mac which triggers this message when running in GPT mode.

We will look into this on Monday.

Danny

tsmoore00
Posts: 14
Joined: Fri Apr 01, 2005 9:31 am America/New_York

GPT mosaic problem with OLCI L2 files

by tsmoore00 » Sat Oct 28, 2017 8:19 am America/New_York

Yes, I should have mentioned running from an iMac.

Thanks!
tim

OB SeaDAS - knowles
Subject Matter Expert
Subject Matter Expert
Posts: 221
Joined: Mon Apr 07, 2008 4:40 pm America/New_York

GPT mosaic problem with OLCI L2 files

by OB SeaDAS - knowles » Wed Nov 01, 2017 6:41 pm America/New_York

Tim,

After sweating this one out a bit, the problem is now correctly understood and resolved!

It is a java versioning problem.  At the command line type:
  java -version

For SeaDAS 7.4, you need version 1.8 of java.  Having version 1.7 or lower will give the error you saw when running gpt at the command line. 

Of note for the Mac: installing and checking the java version via the System Preferences GUI does not mean that the terminal version is actually updated.  You will most likely need to download and install java directly (http://www.oracle.com/technetwork/java/javase/downloads/index.html).

Danny

tsmoore00
Posts: 14
Joined: Fri Apr 01, 2005 9:31 am America/New_York

GPT mosaic problem with OLCI L2 files

by tsmoore00 » Thu Nov 02, 2017 3:02 pm America/New_York

Hi Danny,

Thanks for finding this out - I'll give it a go.

Sorry to make you sweat,
Tim

tsmoore00
Posts: 14
Joined: Fri Apr 01, 2005 9:31 am America/New_York

GPT mosaic problem with OLCI L2 files

by tsmoore00 » Thu Nov 02, 2017 3:44 pm America/New_York

Hi Danny,

Yes, that did work. Nice job.

Thanks,
Tim

Post Reply