modis_GEO.py failing; no output; returns 0

Please enter here to ask a question about any NASA Science related topics!
Post Reply
7yl4r
Posts: 27
Joined: Tue Jul 18, 2017 10:07 am America/New_York

modis_GEO.py failing; no output; returns 0

by 7yl4r » Tue Jan 16, 2018 10:33 am America/New_York

modis_GEO.py in ocssw 7.4 is failing to produce any output file or stdout/stderr. This same call was working at most two weeks ago and is no longer working using the same input files. My call to the script looks like:

```
export OCSSWROOT=/opt/ocssw && source /opt/ocssw/OCSSW_bash.env && \
/opt/ocssw/run/scripts/modis_GEO.py \
--verbose \
--output=/srv/imars-objects/modis_aqua_gom/geo/A2002191183500.GEO \
/srv/imars-objects/modis_aqua_gom/myd01/A2002191.1835.hdf
```

There is no output, the script returns 0, and the expected output file `/srv/imars-objects/modis_aqua_gom/geo/A2002191183500.GEO` does not exist.

All I can tell from looking at the code is that the problem is likely `modules/modis_GEO_utils.py` giving up silently somewhere.
Suggestions on how to debug this further?

Tags:

gfireman
Posts: 59
Joined: Thu Jan 07, 2010 2:59 pm America/New_York

modis_GEO.py failing; no output; returns 0

by gfireman » Tue Jan 16, 2018 11:49 am America/New_York

Adding "--log" to your invocation will leave all of the processing log files in the output directory.  The LogStatus file is most likely to have useful diagnostics.

7yl4r
Posts: 27
Joined: Tue Jul 18, 2017 10:07 am America/New_York

modis_GEO.py failing; no output; returns 0

by 7yl4r » Tue Jan 16, 2018 2:29 pm America/New_York

Thanks for the tip, @gfireman. I just tried again with the added `--log` to the call and have no log files in my output dir or my current dir.

7yl4r
Posts: 27
Joined: Tue Jul 18, 2017 10:07 am America/New_York

modis_GEO.py failing; no output; returns 0

by 7yl4r » Tue Jan 16, 2018 2:38 pm America/New_York

To be sure it is not a permissions  or network file i/o issue I am now testing using root user in home directory and getting the same result. No output at all.


[root@imars-airflow12 tmp]# export OCSSWROOT=/opt/ocssw && source /opt/ocssw/OCSSW_bash.env && /opt/ocssw/run/scripts/modis_GEO.py --verbose --log --output=/root/tmp/test.hdf /root/tmp/A2002191.1835.hdf && echo $? && ls -lah /root/tmp/
0
total 4.0K
drwxr-xr-x.  2 root root   31 Jan 16 19:33 .
dr-xr-x---. 12 root root 4.0K Dec 21 20:59 ..
-rw-r--r--.  1 root root    0 Jan 16 19:33 A2002191.1835.hdf

7yl4r
Posts: 27
Joined: Tue Jul 18, 2017 10:07 am America/New_York

modis_GEO.py failing; no output; returns 0

by 7yl4r » Tue Jan 16, 2018 2:43 pm America/New_York

I think I see the issue. My NFS share is acting up, for some reason causing files to read as empty.

Thanks for taking a look and please take this as a feature request: "modis_GEO.py should return error when passed a malformed input file"

Is there a guide to submitting pull requests?

Post Reply