modis_L1B.py not making HKM file for A2019120081000.L1A_LAC

Please enter here to ask a question about any NASA Science related topics!
Post Reply
alaroy
Posts: 63
Joined: Tue Nov 21, 2006 3:33 pm America/New_York

modis_L1B.py not making HKM file for A2019120081000.L1A_LAC

by alaroy » Tue Apr 30, 2019 12:30 pm America/New_York

Good morning.

For some reason the command

modis_L1B.py A2019120081000.L1A_LAC A2019120081000.GEO

is not currently generating the expected A2019120081000.L1B_HKM file. It's a silent failure with no errors / warnings / etc. Any ideas as to what is going wrong?

PS I also tried modis_L1B.py --hkm=A2019120081000.L1B_HKM A2019120081000.L1A_LAC A2019120081000.GEO which also failed silently

-Andrew L.

Tags:

OB.DAAC - SeanBailey
User Services
User Services
Posts: 1223
Joined: Wed Sep 18, 2019 6:15 pm America/New_York
Answers: 1

modis_L1B.py not making HKM file for A2019120081000.L1A_LAC

by OB.DAAC - SeanBailey » Tue Apr 30, 2019 2:19 pm America/New_York

The file is a nighttime granule - makes no sense to generate the HKM and QKM files as they contain only reflective solar bands....no Sun, no data...

$ ncdump_hdf A2019120081000.L1A_LAC |grep -A5  DAYNIGHTFLAG
    "    OBJECT                 = DAYNIGHTFLAG\n",
    "      NUM_VAL              = 1\n",
    "      VALUE                = \"Night\"\n",
    "    END_OBJECT             = DAYNIGHTFLAG\n",
    "\n",


If you REALLY want them, you will have to modify the PCF file and set the write bit for night mode:
($OCDATAROOT/modis/pcf/L1B_template.pcf)
# ----------------------------------------------------------------------
# The following parameter determines whether the 250m and 500m data sets
# will be written out when all scans in a granule are NIGHT mode.  To
# enable writing out night mode High Resolution data, set the flag to 1;
# to disable, set to 0.
# ----------------------------------------------------------------------
800615|Write_Night_Mode_HiRes_Data|0


Sean

alaroy
Posts: 63
Joined: Tue Nov 21, 2006 3:33 pm America/New_York

modis_L1B.py not making HKM file for A2019120081000.L1A_LAC

by alaroy » Tue Apr 30, 2019 4:38 pm America/New_York

Thank you Sean, that would make sense...

For some reason that night time granule turned up in a subscription that was supposed to be day only (id #2130) you might want to double check the selection logic.

OB.DAAC - SeanBailey
User Services
User Services
Posts: 1223
Joined: Wed Sep 18, 2019 6:15 pm America/New_York
Answers: 1

modis_L1B.py not making HKM file for A2019120081000.L1A_LAC

by OB.DAAC - SeanBailey » Tue Apr 30, 2019 6:29 pm America/New_York

Day time only subscriptions include "mixed" granules (those that contain both day and night).  In our processing that file is considered "mixed",  although it just barely clips the terminator.  The MODIS GEO code considers it night only.  This can happen, but 'tis rare.

Sean

alaroy
Posts: 63
Joined: Tue Nov 21, 2006 3:33 pm America/New_York

modis_L1B.py not making HKM file for A2019120081000.L1A_LAC

by alaroy » Wed May 01, 2019 11:50 pm America/New_York

Sean,

Thank you for the explanation. It sounds like that granule has a bit of an "identity crisis"...

I ended up changing my scripts to ignore abnormally small L1A files.

-Andrew L.

Post Reply