getfile not working

Please enter here to ask a question about any NASA Science related topics!
Post Reply
alaroy
Posts: 63
Joined: Tue Nov 21, 2006 3:33 pm America/New_York

getfile not working

by alaroy » Thu Aug 08, 2019 11:13 pm America/New_York

When I try to download data with the getfile api it fails with an error of the form

$ wget --no-use-server-timestamps --read-timeout=10 -O /tmp/A2019219181000.L1A_LAC.bz2 https://oceandata.sci.gsfc.nasa.gov/cgi/getfile/A2019219181000.L1A_LAC.bz2
--2019-08-09 02:58:51--  https://oceandata.sci.gsfc.nasa.gov/cgi/getfile/A2019219181000.L1A_LAC.bz2
Resolving oceandata.sci.gsfc.nasa.gov (oceandata.sci.gsfc.nasa.gov)... xx.xxx.xx.xx, 2001:4d0:2418:128::84
Connecting to oceandata.sci.gsfc.nasa.gov (oceandata.sci.gsfc.nasa.gov)|xx.xxx.xx.xx|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2019-08-09 02:58:56 ERROR 404: Not Found.

And creates a 0 length file.

$ ls -l /tmp/A2019219181000.L1A_LAC.bz2
-rw-rw-r--. 1 alaroy alaroy 0 Aug  9 02:58 /tmp/A2019219181000.L1A_LAC.bz2

I'm having the same problem from several servers.

We still have a team out trying to do field validations, so if you could please investigate and get this resolved quickly it would be much appreciated.

-Andrew L.

Tags:

oo_processing
Posts: 211
Joined: Wed Apr 06, 2005 12:11 pm America/New_York

getfile not working

by oo_processing » Thu Aug 08, 2019 11:59 pm America/New_York


alaroy
Posts: 63
Joined: Tue Nov 21, 2006 3:33 pm America/New_York

getfile not working

by alaroy » Fri Aug 09, 2019 7:27 am America/New_York

Brock,

It looks like the download issue you're seeing is affecting everything not just the ancillary data.

On a whim I checked our other subscriptions (which are all for L2 data). It looks like we stopped downloading any new data between 15:00 and 17:00 UTC yesterday (8/8).

-Andrew L.

OB ODPS - towens
Subject Matter Expert
Subject Matter Expert
Posts: 164
Joined: Fri Feb 05, 2021 9:17 am America/New_York

getfile not working

by OB ODPS - towens » Fri Aug 09, 2019 7:32 am America/New_York

They are two different issues. Brock was trying to retrieve files that didn't exist. The L1A files you need are on the server but getfile cannot retrieve them from the hosts.
We are working on a resolution.

Tommy

OB ODPS - towens
Subject Matter Expert
Subject Matter Expert
Posts: 164
Joined: Fri Feb 05, 2021 9:17 am America/New_York

getfile not working

by OB ODPS - towens » Fri Aug 09, 2019 12:16 pm America/New_York

The problem affecting the file servers has been resolved.

Tommy

Post Reply