The issue of l2gen processing Landsat 7.

Please enter here to ask a question about any NASA Science related topics!
Post Reply
qqq196988
Posts: 3
Joined: Tue Apr 27, 2021 9:44 pm America/New_York

The issue of l2gen processing Landsat 7.

by qqq196988 » Tue Apr 27, 2021 9:58 pm America/New_York

Hello everyone

I try to use l2gen to process Landsat 7, but 478nm(Blue) band Processing failed.(all Nan). Other bands are normal.
I use the same command line to process Landsat 8,it normal. Anyone know the problem?

Tags:

OB SeaDAS - xuanyang02
Subject Matter Expert
Subject Matter Expert
Posts: 66
Joined: Tue Feb 09, 2021 5:42 pm America/New_York

Re: The issue of l2gen processing Landsat 7.

by OB SeaDAS - xuanyang02 » Wed Apr 28, 2021 3:49 pm America/New_York

According to the 2019 post: viewtopic.php?f=7&t=1759&p=5659&hilit=L ... 6b44#p5659

The l2gen code *does* have support for Landsat 5 & 7 - but it may not be fully baked, so we've not really advertised it. In fact, it requires a bit of manual intervention to get the required data files installed. Landsat 8 is fully supported.

If you give us more information as to what you did with Landsat 8 data and what you are trying to do with Landsat 7 data, one of our experts might be able to point you at how to get L7 working...

qqq196988
Posts: 3
Joined: Tue Apr 27, 2021 9:44 pm America/New_York

Re: The issue of l2gen processing Landsat 7.

by qqq196988 » Wed Apr 28, 2021 9:29 pm America/New_York

Thanks. Is there no solution to this problem? What should i do to make blue-band of Landsat 7(ETM+) after atmospheric correction normal?

Post Reply