OCSSW Installation Error

Please enter here to ask a question about any NASA Science related topics!
avmehta
Posts: 148
Joined: Mon Feb 03, 2020 10:27 am America/New_York

OCSSW Installation Error

by avmehta » Tue Jun 22, 2021 10:41 am America/New_York

Hello,
I have installed SeaDAS-8 on my linux machine (it is a container on NCCS adapt). Now I am trying to install ocssw (using install_ocssw.py)
After getting files for various sensors I get the following errors:

Installing bin (19 of 25)
fatal: Not a git repository (or any parent up to mount point /att/gpfsfs/briskfs01)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
fatal: Not a git repository (or any parent up to mount point /att/gpfsfs/briskfs01)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
fatal: Not a git repository (or any parent up to mount point /att/gpfsfs/briskfs01)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
Error - Could not run "cd /att/nobackup/avmehta/seadas8/bin; git fetch -q > /dev/null"

Please advice on how to proceed.
Thank you.
Amita

Tags:

OB SeaDAS - xuanyang02
Subject Matter Expert
Subject Matter Expert
Posts: 130
Joined: Tue Feb 09, 2021 5:42 pm America/New_York

Re: OCSSW Installation Error

by OB SeaDAS - xuanyang02 » Tue Jun 22, 2021 11:13 am America/New_York

Amita,

install_ocssw.py is now install_ocssw. Please see https://seadas.gsfc.nasa.gov/downloads/

Thanks,

Bing

avmehta
Posts: 148
Joined: Mon Feb 03, 2020 10:27 am America/New_York

Re: OCSSW Installation Error

by avmehta » Tue Jun 22, 2021 4:48 pm America/New_York

Hello Bing,
Thanks for the correct link. I tried to follow the direction but I get the following error in manifest.py

File "/att/gpfsfs/briskfs01/ppl/avmehta/seadas8/manifest.py", line 16, in <module>
import requests
ModuleNotFoundError: No module named 'requests'


where can I get this module?
Thanks.
Amita

OB SeaDAS - xuanyang02
Subject Matter Expert
Subject Matter Expert
Posts: 130
Joined: Tue Feb 09, 2021 5:42 pm America/New_York

Re: OCSSW Installation Error

by OB SeaDAS - xuanyang02 » Tue Jun 22, 2021 5:02 pm America/New_York

Amita,

Your manifest.py should be in /att/gpfsfs/briskfs01/ppl/avmehta/seadas8/ocssw/bin. I don't know if you have done SeaDAS-OCSSW -> COnfigure OCSSW right.

Can you do SeaDAS-OCSSW -> SeaDAS/System Info on GUI and post the output here?

Thanks,

Bing

avmehta
Posts: 148
Joined: Mon Feb 03, 2020 10:27 am America/New_York

Re: OCSSW Installation Error

by avmehta » Tue Jun 22, 2021 7:59 pm America/New_York

Hi Bing,
On my mac I used GUI and OCSSW was installed without any problem.
On adapt/linux GUI is very slow.
Can you be more specific about SeaDAS-OCSSW -> COnfigure OCSSW?
I don't see /att/gpfsfs/briskfs01/ppl/avmehta/seadas8/ocssw/. I just downloaded install_ocssw and manifest.py in the seadas directory.
Then I used the following
./install_ocssw --install_dir=/att/nobackup/avmehta/seadas8 --tag V2020.2 --oli --msis2a --msis2b --olcis3a --olcis3b --aqua --terra --viirsn --viirsj1

Thanks.
Amita

OB.DAAC - SeanBailey
User Services
User Services
Posts: 1169
Joined: Wed Sep 18, 2019 6:15 pm America/New_York

Re: OCSSW Installation Error

by OB.DAAC - SeanBailey » Wed Jun 23, 2021 9:51 am America/New_York

Amita,

The requests module is a python module and is required by the scripts that connect to our servers. See: https://seadas.gsfc.nasa.gov/requirements/

Sean

OB SeaDAS - xuanyang02
Subject Matter Expert
Subject Matter Expert
Posts: 130
Joined: Tue Feb 09, 2021 5:42 pm America/New_York

Re: OCSSW Installation Error

by OB SeaDAS - xuanyang02 » Wed Jun 23, 2021 10:41 am America/New_York

Amita,

SeaDAS-OCSSW -> Configure OCSSW is also on GUI.

Can you make sure you are using python3?
"$ python3 --version"

You can do "$ python -m pip install requests" to get the requests module.

Bing

avmehta
Posts: 148
Joined: Mon Feb 03, 2020 10:27 am America/New_York

Re: OCSSW Installation Error

by avmehta » Wed Jun 23, 2021 11:31 am America/New_York

Hi Sean,
Thanks for the information. I downloaded the request Library. When I try to install it I get the following:

Singularity> python -m pip install requests
Defaulting to user installation because normal site-packages is not writeable
Requirement already satisfied: requests in /usr/local/lib/python3.7/site-packages (2.22.0)
Requirement already satisfied: idna<2.9,>=2.5 in /usr/local/lib/python3.7/site-packages (from requests) (2.8)
Requirement already satisfied: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in /usr/local/lib/python3.7/site-packages (from requests) (1.24.3)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /usr/local/lib/python3.7/site-packages (from requests) (3.0.4)
Requirement already satisfied: certifi>=2017.4.17 in /usr/local/lib/python3.7/site-packages (from requests) (2020.4.5.1)
Could not build wheels for requests, since package 'wheel' is not installed.
Could not build wheels for idna, since package 'wheel' is not installed.
Could not build wheels for urllib3, since package 'wheel' is not installed.
Could not build wheels for chardet, since package 'wheel' is not installed.
Could not build wheels for certifi, since package 'wheel' is not installed.
WARNING: You are using pip version 20.1; however, version 21.1.2 is available.
You should consider upgrading via the '/usr/bin/python -m pip install --upgrade pip' command.

May be I need Wheel! I see a link to wheel but don't actually see what to download!
Thank you.
Amita

OB.DAAC - SeanBailey
User Services
User Services
Posts: 1169
Joined: Wed Sep 18, 2019 6:15 pm America/New_York

Re: OCSSW Installation Error

by OB.DAAC - SeanBailey » Wed Jun 23, 2021 11:41 am America/New_York

Amita,

See https://packaging.python.org/tutorials/ ... -packages/

or if you don't want to read :D

Code: Select all

python3 -m pip install --upgrade pip setuptools wheel
Sean

gnwiii
Posts: 606
Joined: Fri Jan 29, 2021 5:51 pm America/New_York
Answers: 1

Re: OCSSW Installation Error

by gnwiii » Wed Jun 23, 2021 7:52 pm America/New_York

avmehta wrote: Tue Jun 22, 2021 7:59 pm America/New_York [...]I used the following
./install_ocssw --install_dir=/att/nobackup/avmehta/seadas8 --tag V2020.2 --oli --msis2a --msis2b --olcis3a --olcis3b --aqua --terra --viirsn --viirsj1
"install_ocssw --help" will show you that there is a "--list_tags" option. You should probably use a 2021.N tag.

Elsewhere you mentioned "access denied" for Python's "site-packages" directory. To avoid creating problems for system packages you can install to a "$HOME/.local" tree or use a virtual environment. For details consult the link Sean posted (https://packaging.python.org/tutorials/ ... -packages/).

Post Reply