SeaDAS 8.1.0 installation error

Please enter here to ask a question about any NASA Science related topics!
Post Reply
Posts: 1
Joined: Fri Jan 05, 2018 11:41 am America/New_York

SeaDAS 8.1.0 installation error

by martakonik » Thu Jul 15, 2021 4:40 am America/New_York

I tried to install the new version of SeaDAS in a console. I got an error below. I tried using several java versions. Nothing helped. Could you please give me a hint what might be the problem? I am using Ubuntu 20.04.2 LTS:

root@toolbox-kontenerowiec4-ubuntu:/opt/seadas# sh ./ --nox11 --accept
Verifying archive integrity... 100% All good.
Uncompressing SeaDAS by Ocean Ecology Lab 100%
Command line arguments:
SEVERE: com.izforge.izpack.api.exception.IzPackException: Console implementation not found for panel: com.izforge.izpack.panels.installationtype.InstallationTypePanel


Posts: 624
Joined: Fri Jan 29, 2021 5:51 pm America/New_York
Answers: 1

Re: SeaDAS 8.1.0 installation error

by gnwiii » Thu Jul 15, 2021 8:22 am America/New_York

I should note that it is not good practice to install SeaDAS as root -- it is a complex GUI application intended to be installed on a per user basis. If you want to use a script for multiple installs (e.g., student workshop) you could consider making a tar archive of a base installation and extracting that as the target user so the files are owned by the user.

On a system with java-1.8.0-openjdk JDK and see the same issue. On a system with X11, the installer opens a GUI window. For IzPack, "-console" is supposed to support a console installation, but adding "-- -console" gives the same "SEVERE" error.

Since SeaDAS 8 is a GUI, you will eventually need X11 (or wayland). It might be useful to mention more details of your use case. It is often possible to use xvfb to provide X11 for batch processing (e.g., with software that used X11 fonts to create png images).

Post Reply