Default time in GIBS WMS requests with time dimension

Please enter here to ask a question about any NASA Science related topics!
Post Reply
clementjonglez
Posts: 2
Joined: Thu Jul 29, 2021 10:52 am America/New_York

Default time in GIBS WMS requests with time dimension

by clementjonglez » Thu Jul 29, 2021 11:39 am America/New_York

Dear all,

I am using the GIBS's OGC Web Map Service (WMS) [https://wiki.earthdata.nasa.gov/display ... rvice(WMS)] in a software which does not support time dimension.

According to the OGC WMS standard, when no time is specified, the default date should be used by the map server.

Also, according to the GIBS's getCapabilities file [https://gibs.earthdata.nasa.gov/wms/eps ... SION=1.3.0], for the layers I am using, the default date should be the current date (or a few days before). For instance at the present time, the default date is 2021-07-27.

However, the results look very different when *manually* specifying 2021-07-27 as the time. And by comparing with FIRMS Fire Map, I am pretty sure that the default date is definitely not 2021-07-27.
For instance, below are two pictures:
* modis-no-date-specified.png: from https://gibs.earthdata.nasa.gov/wms/eps ... 180,90,180
* modis-2021-07-27: from https://gibs.earthdata.nasa.gov/wms/eps ... 2021-07-27
Only the second picture actually matches the wild fires on 2021-07-27.

I am using the following layers:
a. MODIS_Combined_Thermal_Anomalies_All
b. VIIRS_NOAA20_Thermal_Anomalies_375m_All
c. VIIRS_SNPP_Thermal_Anomalies_375m_All

Furthermore, there is another issue: with layer a. (MODIS), not specifying any time, a default time is used, the wrong one, but still an image is returned. However, layers b. and c. throw the following error in this case:
"msDrawMap(): Image handling error. Failed to draw layer named 'VIIRS_SNPP_Thermal_Anomalies_375m_All'. msShapefileOpen(): Unable to access file. (/archive/geographic/other/shapefiles/firms/FIRMS_SNPP_LL_LNK//YYYY/FIRMS_SNPP_LL_LNKTTTTTTT_) "
For instance I tried with this URL https://gibs.earthdata.nasa.gov/wms/eps ... 180,90,180
Which contradicts GIBS's documentation when no time is specified: https://wiki.earthdata.nasa.gov/display ... imension.1

Best regards
Clément
Attachments
MODIS, no date specified
MODIS, no date specified
modis-no-date-specified.png (49.18 KiB) Not viewed yet
MODIS, date specified 2021-07-27
MODIS, date specified 2021-07-27
modis-2021-07-27.png (53.75 KiB) Not viewed yet

Tags:

rboller
Posts: 2
Joined: Thu May 27, 2021 2:52 pm America/New_York

Re: Default time in GIBS WMS requests with time dimension

by rboller » Fri Aug 06, 2021 4:39 pm America/New_York

Hi Clément,

Thanks for your report - we're aware of this issue and will provide further details next week.

Regards,
Ryan

adeluca
Posts: 1
Joined: Wed Aug 11, 2021 12:15 pm America/New_York

Re: Default time in GIBS WMS requests with time dimension

by adeluca » Wed Aug 11, 2021 12:18 pm America/New_York

Hi Clément,

We have found the issue and are going to test a fix this week. We'll let you know when everything is resolved.

Thanks for your patience,
Alex

clementjonglez
Posts: 2
Joined: Thu Jul 29, 2021 10:52 am America/New_York

Re: Default time in GIBS WMS requests with time dimension

by clementjonglez » Tue Sep 07, 2021 8:00 am America/New_York

Hi Alex,

Thank you for finding the issue, I am looking forward to the fix.

Best regards
Clément

Post Reply