Update the ocssw processors failed

Please enter here to ask a question about any NASA Science related topics!
treble
Posts: 20
Joined: Thu Jan 24, 2008 1:33 pm America/New_York

Update the ocssw processors failed

by treble » Mon Feb 06, 2017 12:31 pm America/New_York

Ah, ok, I see.  I was confused because inymar wrote that 'everything' worked.

I am not sure if the 'Get Ancillary' is working in l2gen when processing a SeaWiFS L2_GAC file.  I just tried it and nothing happens when I click Get Ancillary (any of the options).  In the panel below it still says ANCILLARY INPUTS Default = climatology.  Also, in the OCSSW_LOG_l2gen.txt it seems it is not using 'real time' data:
  met1   = /Applications/seadas-7.3/ocssw/run/data/common/met_climatology_v2014.hdf
  ozone1 = /Applications/seadas-7.3/ocssw/run/data/common/ozone_climatology_v2014.hdf
  no2    = /Applications/seadas-7.3/ocssw/run/data/common/no2_climatology_v2013.hdf

Tags:

OB.DAAC - SeanBailey
User Services
User Services
Posts: 1171
Joined: Wed Sep 18, 2019 6:15 pm America/New_York

Update the ocssw processors failed

by OB.DAAC - SeanBailey » Tue Feb 07, 2017 10:05 am America/New_York

Hmmm...worked for me.  What file were you trying to process and (if you can recall) about when did you attempt (so we can see if there's anything in the logs)

Sean

treble
Posts: 20
Joined: Thu Jan 24, 2008 1:33 pm America/New_York

Update the ocssw processors failed

by treble » Tue Feb 07, 2017 6:05 pm America/New_York

Strange, I tried a couple just now...
S2003239163104.L1A_GAC
S2000243154434.L1A_GAC

env | grep anc gives: L2GEN_ANC=/Applications/seadas-7.3/ocssw/run/var/anc
ls /Applications/seadas-7.3/ocssw/run/var/anc gives 2015 (so no year 2000 or 2003...).

The log says:

Opening meteorological files.
  met1   = /Applications/seadas-7.3/ocssw/run/data/common/met_climatology_v2014.hdf
  met2   =
  met3   =
  ozone1 = /Applications/seadas-7.3/ocssw/run/data/common/ozone_climatology_v2014.hdf
  ozone2 =
  ozone3 =
  no2    = /Applications/seadas-7.3/ocssw/run/data/common/no2_climatology_v2013.hdf


OB.DAAC - SeanBailey
User Services
User Services
Posts: 1171
Joined: Wed Sep 18, 2019 6:15 pm America/New_York

Update the ocssw processors failed

by OB.DAAC - SeanBailey » Tue Feb 07, 2017 7:04 pm America/New_York

Well, sitting on my couch (so just like very other SeaDAS user :wink:):

$ getanc.py --verbose S2003239163104.L1A_GAC
Searching database: /Users/Shared/seadas-7.3/ocssw/run/var/ancillary_data.db
Determining pass start and end times...

Input file: S2003239163104.L1A_GAC
Start time: 2003239163103
End time: 2003239171443

Downloading 'N200323918_MET_NCEPR2_6h.hdf' to /Users/Shared/seadas-7.3/ocssw//run/var/anc/2003/239
  Found: /Users/Shared/seadas-7.3/ocssw//run/var/anc/2003/239/N200323918_MET_NCEPR2_6h.hdf
Downloading 'N200323912_MET_NCEPR2_6h.hdf' to /Users/Shared/seadas-7.3/ocssw//run/var/anc/2003/239
Downloading 'N200323900_O3_EPTOMS_24h.hdf' to /Users/Shared/seadas-7.3/ocssw//run/var/anc/2003/239
Downloading 'N200324000_O3_EPTOMS_24h.hdf' to /Users/Shared/seadas-7.3/ocssw//run/var/anc/2003/240
  Found: /Users/Shared/seadas-7.3/ocssw//run/var/anc/2003/240/N200324000_O3_EPTOMS_24h.hdf
Downloading 'N2003239_SST_OIV2AVAM_24h.nc' to /Users/Shared/seadas-7.3/ocssw//run/var/anc/2003/239
Downloading 'N200323900_SEAICE_NSIDC_24h.hdf' to /Users/Shared/seadas-7.3/ocssw//run/var/anc/2003/239

Created 'S2003239163104.L1A_GAC.anc' l2gen parameter text file:

icefile=/Users/Shared/seadas-7.3/ocssw//run/var/anc/2003/239/N200323900_SEAICE_NSIDC_24h.hdf
met1=/Users/Shared/seadas-7.3/ocssw//run/var/anc/2003/239/N200323912_MET_NCEPR2_6h.hdf
met2=/Users/Shared/seadas-7.3/ocssw//run/var/anc/2003/239/N200323918_MET_NCEPR2_6h.hdf
met3=/Users/Shared/seadas-7.3/ocssw//run/var/anc/2003/239/N200323918_MET_NCEPR2_6h.hdf
ozone1=/Users/Shared/seadas-7.3/ocssw//run/var/anc/2003/239/N200323900_O3_EPTOMS_24h.hdf
ozone2=/Users/Shared/seadas-7.3/ocssw//run/var/anc/2003/240/N200324000_O3_EPTOMS_24h.hdf
ozone3=/Users/Shared/seadas-7.3/ocssw//run/var/anc/2003/240/N200324000_O3_EPTOMS_24h.hdf
sstfile=/Users/Shared/seadas-7.3/ocssw//run/var/anc/2003/239/N2003239_SST_OIV2AVAM_24h.nc

- All optimal ancillary data files were determined and downloaded. -


Perhaps there is a network issue when you try?
Try running manually, using --verbose and --refreshDB  to see if you get anything like:
Connection error, retrying up to 5 more time(s)
...


Sean

treble
Posts: 20
Joined: Thu Jan 24, 2008 1:33 pm America/New_York

Update the ocssw processors failed

by treble » Wed Feb 08, 2017 4:56 pm America/New_York

Thanks for testing...

From the command line getting ancillary data works fine for me, thanks for the reminder.
When I do the following:
From the GUI, start l2gen, and click on "Get Ancillary", I get a pop-up window for a 5-10 seconds with "Retrieving ancillary files", but the window below doesn't get updated, nor is anything downloaded in my L2GEN_ANC directory.
Issuing getanc.py from the command line downloads the files with no problem.
Going back to the GUI and clicking on "Get Ancillary" now works.  The files get listed in the window frame below...

So the downloading only doesn't work from the GUI.  It will use them when they are already downloaded.  Maybe still an http/https thing?

madhur
Posts: 7
Joined: Sun Dec 04, 2016 11:01 am America/New_York

Update the ocssw processors failed

by madhur » Wed Feb 08, 2017 5:21 pm America/New_York

When trying to update SeaDAS using the help provided in the page - https://seadas.gsfc.nasa.gov/installers/ , I downloaded installer script, ran the command - chmod +x install_ocssw.py and while trying to run the installer using this command -
ws135-54:installer madhur$ sudo ./install_ocssw.py --install-dir=/Applications/seadas-7.3.2/ocssw/  --git-branch=7.3 --aqua --seawifs

following error appeared :

ws135-54:installer madhur$ sudo ./install_ocssw.py --install-dir=/Applications/seadas-7.3.2/ocssw/  --git-branch=7.3 --aqua --seawifs
Password:
Installing bundles.sha256sum (1 of 15)
--2017-02-08 16:01:34--  https://oceandata.sci.gsfc.nasa.gov/ocssw/bundles.sha256sum
Resolving oceandata.sci.gsfc.nasa.gov... xx.xxx.xx.xx, 2001:4d0:2418:128::84
Connecting to oceandata.sci.gsfc.nasa.gov|xx.xxx.xx.xx|:443... connected.
Unable to establish SSL connection.
Error - Executing command "cd /Applications/seadas-7.3.2/ocssw; wget --tries=5 --wait=5 https://oceandata.sci.gsfc.nasa.gov/ocssw/bundles.sha256sum"
Bundle checksum file (bundles.sha256sum) not downloaded
ws135-54:installer madhur$

My OS X El Capitan version 10.11.6

I am not verse in terminal and mac OS. So could you help me to diagnose the problem and help me to solve it?

Thanks,
Madhur

OB.DAAC - SeanBailey
User Services
User Services
Posts: 1171
Joined: Wed Sep 18, 2019 6:15 pm America/New_York

Update the ocssw processors failed

by OB.DAAC - SeanBailey » Wed Feb 08, 2017 6:14 pm America/New_York

that is odd, as my test worked both from the GUI and the command line...I'm a wee bit stumped...

OB.DAAC - SeanBailey
User Services
User Services
Posts: 1171
Joined: Wed Sep 18, 2019 6:15 pm America/New_York

Update the ocssw processors failed

by OB.DAAC - SeanBailey » Wed Feb 08, 2017 6:21 pm America/New_York

Couple of things...

The  branch includes the 'v' prefix, so the --git-branch option should be "--git-branch=v7.3"

You'll also need an alternate version of python as the Apple provided version does not support SSL in the manner required to make a connection to our servers.
see: https://oceancolor.gsfc.nasa.gov/forum/oceancolor/topic_show.pl?pid=27730

Sean

treble
Posts: 20
Joined: Thu Jan 24, 2008 1:33 pm America/New_York

Update the ocssw processors failed

by treble » Wed Feb 08, 2017 7:00 pm America/New_York

@madhur: see my post above on the steps to take.  You probably only have to install Anaconda, with python 2.7:

"
I installed Anaconda following Sean's recommendation ( https://www.continuum.io/downloads ).  I now have:
python --version: Python 2.7.13 :: Anaconda 4.3.0 (x86_64)
openssl version: OpenSSL 1.0.2k  26 Jan 2017

I reinstalled SeaDAS, installed OCSSW packages from the command line as follows with the latest install_ocssw.py script:
./install_ocssw.py --install-dir=$OCSSWROOT --git-branch=v7.3 --aqua --seawifs

Updating luts from the command line with the update_luts.py script works fine.  I can also create GEO files from the command line with the modis_GEO.py script.
"

gnwiii
Posts: 606
Joined: Fri Jan 29, 2021 5:51 pm America/New_York
Answers: 1

Update the ocssw processors failed

by gnwiii » Wed Feb 08, 2017 7:45 pm America/New_York

First, it is best to avoid installing the OCSSW processing system with "sudo".  Most users will want to install it in a normal user account without special permissions. 
As previously discussed in these forums, Apple's python uses an obsolete ssl library.  You will need to install a different python with current SSL support (Anaconda python and macports python are both known to work).  You will need to make sure the PATH variable is set so the new python is used.

Post Reply