Java JRE issue

Use this Forum to find information on, or ask a question about, NASA Earth Science data.
Post Reply
eko1968
Posts: 9
Joined: Mon Feb 26, 2007 9:20 pm America/New_York

Java JRE issue

by eko1968 » Mon May 02, 2022 1:30 am America/New_York

Hello,

I have just installed SeaDAS 8.2 on Ubuntu 20.04.
But when I run it, I have a fatal error message like below:
=====
Failed to load module "canberra-gtk-module"
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007fcbdc036d0c, pid=13516, tid=0x00007fcbdc24e700
#
# JRE version: Java(TM) SE Runtime Environment (8.0_201-b09) (build 1.8.0_201-b09)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.201-b09 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C [libdrm_nouveau.so.2+0x4d0c]
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /home/eko/hs_err_pid13516.log
.
.
.
======

Oracle Java JRE was already installed.
eko@eko-ubuntu:~$ java -version
java version "1.8.0_331"
Java(TM) SE Runtime Environment (build 1.8.0_331-b09)
Java HotSpot(TM) 64-Bit Server VM (build 25.331-b09, mixed mode)

Do I need to install Java JDK too?
Thank you for your suggestions.

Regards,

Tags:

OB SeaDAS - aynur
Subject Matter Expert
Subject Matter Expert
Posts: 40
Joined: Tue Dec 20, 2011 12:28 pm America/New_York

Re: Java JRE issue

by OB SeaDAS - aynur » Tue May 03, 2022 11:52 am America/New_York

Hi there,

Please check if you have "canberra-gtk-module" installed using the following command:

$ locate libcanberra-gtk-module.so

The result should be the following or one of these two:
/usr/lib/x86_64-linux-gnu/gtk-2.0/modules/libcanberra-gtk-module.so
/usr/lib/x86_64-linux-gnu/gtk-3.0/modules/libcanberra-gtk-module.so

If you don't have the "locate"command, you can check the /usr/lib/x86_64-linux-gnu/gtk-2.0/modules/ directory or the /usr/lib/x86_64-linux-gnu/gtk-3.0/modules/ directory for the existence of the libcanberra-gtk-module.so file. If you don't see this file, install it using the following command:

sudo apt-get install libcanberra-gtk-module

If you have the "canberra-gtk-module" installed but still having the error message, then set the LD_LIBRARY_PATH in your default shell script or before you run SeaDAS:

$ LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu/gtk-3.0/modules/:$LD_LIBRARY_PATH

eko1968
Posts: 9
Joined: Mon Feb 26, 2007 9:20 pm America/New_York

Re: Java JRE issue

by eko1968 » Wed May 04, 2022 12:06 am America/New_York

Hello
By installing libcanberra-gtk-module solved the problem.
Thank you very much.

Post Reply