L8 - OLI

Use this Forum to find information on, or ask a question about, NASA Earth Science data.
Post Reply
Posts: 184
Joined: Mon Feb 03, 2020 10:27 am America/New_York
Answers: 0
Been thanked: 1 time

L8 - OLI

by avmehta » Tue May 17, 2022 4:13 pm America/New_York

I have been trying to process OLI Level-1 data to get Level-2 on a Linux machine via a script I have written a couple of years ago. Everything has worked fine till mid-March. Now when getanc.py is called I get the following:
ERROR: For LC08_L1TP_014033_20210623_20210629_01_T1_MTL.txt could not determine: start time, start date, stoptime, stop date. Exiting.
l1info reported the following error:
b"-E- clo_readFile: Can't open parameter file - /usr/local/cb/ocssw//common/msl12_defaults.par\n"

Similar error with lonlat2pixline:
Loading default parameters from /usr/local/cb/ocssw//common/msl12_defaults.par
-E- clo_readFile: Can't open parameter file - /usr/local/cb/ocssw//common/msl12_defaults.par

I notice the path /usr/local/cb/ocssw//common/
I see the msl12_defaults.par on /usr/local/cb/ocssw/share/common/
My OCDATAROOT is set to /usr/local/cb/ocssw
This script worked fine -- now all of a sudden it is not working!
Any suggestion?
Thank you.


OB SeaDAS - xuanyang02
Subject Matter Expert
Subject Matter Expert
Posts: 660
Joined: Tue Feb 09, 2021 5:42 pm America/New_York
Answers: 1
Been thanked: 2 times

Re: L8 - OLI

by OB SeaDAS - xuanyang02 » Tue May 17, 2022 5:50 pm America/New_York


Your OCDATAROOT should be set to /usr/local/cb/ocssw/share while your OCSSWROOT is /usr/local/cb/ocssw/


Post Reply