SAGE III Download Problem

Use this Forum to find information on, or ask a question about, NASA Earth Science data.
Post Reply
Posts: 284
Joined: Thu Jul 11, 2019 4:32 pm America/New_York
Answers: 3

SAGE III Download Problem

by EarthdataForumContributor » Tue Oct 06, 2020 2:12 pm America/New_York

i am a staff member of the University of Greifswald in Germany, in the environmental physics research group.
i tried to download the whole SAGE-III-M3M level 2 solar occultation hdf data set, but was not able to. I tried the provided on this page, i tried filezilla and i couldn't even manually download a single file from the download link list. It always tried to connect to the server but then failed to do so. For example with the download script the error message, that came after 2 minutes was: "curl: (28) Failed to connect to port 21: Connection timed out".
Can you help me here? Is this a problem on my side or on the server side?
Thank you for your time already in advance


ASDC - mcook
User Services
User Services
Posts: 89
Joined: Wed Sep 25, 2019 10:53 am America/New_York
Answers: 0
Has thanked: 1 time

Re: SAGE III Download Problem

by ASDC - mcook » Tue Oct 06, 2020 2:18 pm America/New_York

Thank you for contacting us with an interest in SAGE III data.
We would like to ask when you ordered SAGE-III-M3M level 2 data what File Transfer Protocol were you using?
If you were trying to use FTP, the ASDC no longer supports FTP. We now use HTTPS sessions to download the data.
We suggest using ASDC's Direct Data Download option for downloading SAGE III M3M Level 2 data which is located here.

You can use our Wget script to download the data onto your computer.
Here are instructions for downloading the entire directory.

This script was provided to user's by our developer. You should be able to download the entire directory.
** This is an example of the script. You should replace your data set in place of the CALIPSO/LID_L1_Exp-Prov-V3-40**

URL= ... rov-V3-40/

cd ~
touch .netrc
echo "machine login $USERNAME password $PASSWORD" > .netrc
chmod 0600 .netrc
touch .urs_cookies
wget --load-cookies ~/.urs_cookies --save-cookies ~/.urs_cookies --auth-no-challenge=on --keep-session-cookies --content-disposition --recursive --wait=60 --no-parent --reject "index.html*" --execute robots=off $URL

Post Reply