L2gen output missing OLCI bands >709 nm

Use this Forum to find information on, or ask a question about, NASA Earth Science data.
Locked
eli_tes
Posts: 6
Joined: Thu Jun 22, 2023 11:09 pm America/New_York
Answers: 0
Been thanked: 1 time

L2gen output missing OLCI bands >709 nm

by eli_tes » Tue Nov 14, 2023 11:46 am America/New_York

Hi, I'm using L2gen in the SeaDAS GUI (version 8.4.0) in Ubuntu. I've noticed that after correcting OLCI images (using aer_opt -3, -10 or -17), the output product doesn't contain any bands > Rrs_709. All bands are selected in the L2gen products tab.

One of the products I'm having this problem with: S3A_OL_1_EFR____20220520T105123_20220520T105423_20220521T111839_0179_085_265_1980_PS1_O_NT_002.SEN3

Is there any other option I'm forgetting to select? Am I using the wrong aerosol correction method? I've seen those bands included in l2gen level-2 output, so I think it must be possible to have them corrected?
Thanks for your help!

Filters:

eli_tes
Posts: 6
Joined: Thu Jun 22, 2023 11:09 pm America/New_York
Answers: 0
Been thanked: 1 time

Re: L2gen output missing OLCI bands >709 nm

by eli_tes » Wed Nov 15, 2023 9:26 am America/New_York

If anyone encounters the same problem: I had to check the bands in Products -> Radiances/Reflectances -> Rrs too, and not just on the right side of the Products tab!

OB SeaDAS - xuanyang02
Subject Matter Expert
Subject Matter Expert
Posts: 657
Joined: Tue Feb 09, 2021 5:42 pm America/New_York
Answers: 1
Been thanked: 2 times

Re: L2gen output missing OLCI bands >709 nm

by OB SeaDAS - xuanyang02 » Tue Nov 21, 2023 4:11 pm America/New_York

Use Rrs_nnn instead of Rrs_vvv as in "Kd_490 Rrs_nnn angstrom aot_865 chlor_a" for l2prod in the Selected Products tab.

I used V2023.3 for the Science Processors (OCSSW)

eli_tes
Posts: 6
Joined: Thu Jun 22, 2023 11:09 pm America/New_York
Answers: 0
Been thanked: 1 time

Re: L2gen output missing OLCI bands >709 nm

by eli_tes » Wed Nov 29, 2023 7:40 am America/New_York

Thank you, that's much faster!

Locked