Problem install ocssw - times out

Use this Forum to find information on, or ask a question about, NASA Earth Science data.
Post Reply
Posts: 17
Joined: Mon Jul 17, 2017 8:36 am America/New_York
Answers: 0

Problem install ocssw - times out

by cliffordoo » Fri Apr 10, 2020 3:05 am America/New_York

Hello everyone,

Just wondering if I am missing a step or a server is down.  I have been trying for a couple days to install ocssw manually.  It gets hung up with the error below.

--2020-04-10 17:02:27--  (try: 5)
Connecting to (|2001:4d0:2418:128::84|:443... connected.
HTTP request sent, awaiting response... No data received.
Giving up.

Error - Executing command "cd /Users/afischer/ocssw; wget --tries=5 --wait=5 --continue"
Tried to download common.bundle 5 times, but failed checksum




Posts: 713
Joined: Fri Jan 29, 2021 5:51 pm America/New_York
Answers: 2
Has thanked: 1 time

Problem install ocssw - times out

by gnwiii » Fri Apr 10, 2020 7:38 am America/New_York

I tried the wget download that failed:

% wget --verbose
--2020-04-10 08:26:39--
Resolving (, 2001:4d0:2418:128::84
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1270826692 (1.2G) [application/octet-stream]
Saving to: ‘common.bundle’

common.bundle       100%[===================>]   1.18G  38.0MB/s    in 32s

2020-04-10 08:27:12 (38.0 MB/s) - ‘common.bundle’ saved [1270826692/1270826692]

If you are getting a much smaller file, you may be getting an html login page.   You can check this with the file command, and if it is html, view in a browser by replacing .bundle with .html.  

Between increased watching Netflix and remote working by people "social distancing", many people are experiencing network problems.   You may have to do your install at a time when your internet is less heavily used.   You can get more control of the downloading process using an "offline install" described in Ocean Data Science Software Repositories to fetch the bundles and then running -v -b v7.5 -l <bundles_location> ....

It is also possible that your wget version has a problem.  Sometimes curl works where wget fails, or you can download the files using a web browser.

Starting yesterday I installed the OCSSW software on a fresh WSL2 install of Ubuntu 20.02 LTS.   wget, curl, and the python scripts all had problems, but I was able to complete the installation (and run the benchmark as a test) after downloading a couple bundles with a web browser.   I have attached detailed notes (.md format is ASCII test with simple markup that makes them a bit more readable, or you can use free tools to get html or pdf versions).  A few highlights:

1.  I had to add a second entry to ~/.netrc for ``

2.  When you extract an architecture dependent git bundle you need to rename the resulting directory.

3.  Check your ancillary files against the sizes from my notes. 

4.  curl gave an internal error which may be an Ubuntu bug.
attachment 1

Post Reply