Installation Issue with Seadas 7.3.2 and processing programs.

Use this Forum to find information on, or ask a question about, NASA Earth Science data.
bertrand_saulquin
Posts: 5
Joined: Mon Feb 13, 2017 9:47 am America/New_York

Installation Issue with Seadas 7.3.2 and processing programs.

by bertrand_saulquin » Mon Feb 13, 2017 10:35 am America/New_York

Dear,
i installed seadas using: ./seadas_7.3.2_linux64_installer.sh
I tried to install the MODIS package with:
./install_ocssw.py --install-dir=./ocssw --aqua --seawifs

It downloaded some packages but at the end i have this error:
fatal: unable to access 'https://oceandata.sci.gsfc.nasa.gov/ocssw/common.git/': gnutls_handshake() failed: Handshake failed
Error - Could not run "cd seadas-7.3.2/ocssw/run/data/common; git fetch -q > /dev/null"

the Issue is in the "git fetch -q > /dev/null" command.

Do yo have any idea of the issue, is the GIT repository still  https://oceandata.sci.gsfc.nasa.gov/ocssw/ ?

Thanks in advance.

Bertrand

Tags:

gnwiii
Posts: 669
Joined: Fri Jan 29, 2021 5:51 pm America/New_York
Answers: 2

Installation Issue with Seadas 7.3.2 and processing programs.

by gnwiii » Mon Feb 13, 2017 12:08 pm America/New_York

You should give some details of the platform in case another reader has already solved your problem.   Some linux distros have git configurations that don't support NASA's https configuration.  For example, if (like many of us), you are using Ubuntu 14.04, a search for "ubuntu git install build-essential" should get you to a post with instructions for installing a current git version.

bertrand_saulquin
Posts: 5
Joined: Mon Feb 13, 2017 9:47 am America/New_York

Installation Issue with Seadas 7.3.2 and processing programs.

by bertrand_saulquin » Mon Feb 13, 2017 1:56 pm America/New_York

Dear,

I am using ubuntu 14.04, git version 2.1.4 is it OK?

following your instruction file:https://seadas.gsfc.nasa.gov/downloads/
i used anaconda and finally downloaded the common.bundle file without error  using :
./install_ocssw.py --install-dir=./ocssw --aqua
./install_ocssw.py --install-dir=./ocssw --src

In my directory  $SEADAS/ocssw/ i get these files:
1270770080 avril 28  2016 common.bundle
févr. 13 18:52 run/

Nevertheless no OCSSW_bash.env file as refered into your instruction file:https://seadas.gsfc.nasa.gov/downloads/
export OCSSWROOT=[SeaDAS_install_dir]/ocssw
source $OCSSWROOT/OCSSW_bash.env

And finally i started seadas again and could access any menu in the OCSSW tab. Clicking onto
install oc processors gave me an "ocsww download problem"

Thanks for support

OB SeaDAS - dshea
Subject Matter Expert
Subject Matter Expert
Posts: 240
Joined: Thu Mar 05, 2009 10:25 am America/New_York

Installation Issue with Seadas 7.3.2 and processing programs.

by OB SeaDAS - dshea » Mon Feb 13, 2017 2:53 pm America/New_York

did this command finish without errors?

./install_ocssw.py --install-dir=./ocssw --aqua

I question this because the install script did not cleanup the "common.bundle" file.  I would suggest deleting the whole directory "./ocssw" and trying again.  I think the install script is getting confused by the leftover fragments for the install when you had an old version of git.

don

gnwiii
Posts: 669
Joined: Fri Jan 29, 2021 5:51 pm America/New_York
Answers: 2

Installation Issue with Seadas 7.3.2 and processing programs.

by gnwiii » Mon Feb 13, 2017 3:35 pm America/New_York

You need to install a newer version of git per the search for "ubuntu git install build-essential"

bertrand_saulquin
Posts: 5
Joined: Mon Feb 13, 2017 9:47 am America/New_York

Installation Issue with Seadas 7.3.2 and processing programs.

by bertrand_saulquin » Tue Feb 14, 2017 7:55 am America/New_York

I deleted the ocssw diretory.
my git version is now 2.11

The error is:
cd $SEADAS/ocssw/run/data/common; git fetch
fatal: unable to access 'https://oceandata.sci.gsfc.nasa.gov/ocssw/common.git/': gnutls_handshake() failed: Handshake failed

GIT configuration
ll .git
total 32
drwxr-sr-x 8    87 févr. 14 13:47 ./
drwxr-sr-x 6  4192 févr. 14 12:39 ../
drwxr-sr-x 2     0 févr. 14 12:38 branches/
-rw-r--r-- 1   277 févr. 14 13:47 config
-rw-r--r-- 1    73 févr. 14 12:38 description
-rw-r--r-- 1     0 févr. 14 12:39 FETCH_HEAD
-rw-r--r-- 1    23 févr. 14 12:38 HEAD
drwxr-sr-x 2     0 févr. 14 12:38 hooks/
-rw-r--r-- 1  9642 févr. 14 12:39 index
drwxr-sr-x 2     0 févr. 14 12:38 info/
drwxr-sr-x 3     0 févr. 14 12:38 logs/
drwxr-sr-x 4     5 févr. 14 12:38 objects/
-rw-r--r-- 1   305 févr. 14 12:38 packed-refs
drwxr-sr-x 4     5 févr. 14 12:38 refs/

vim .git/config:
[core]
        repositoryformatversion = 0
        filemode = true
        bare = false
        logallrefupdates = true
[remote "origin"]
        url = https://oceandata.sci.gsfc.nasa.gov/ocssw/common.git
        fetch = +refs/heads/*:refs/remotes/origin/*
[branch "master"]
        remote = origin
        merge = refs/heads/master

Thanks for help

OB.DAAC - SeanBailey
User Services
User Services
Posts: 1313
Joined: Wed Sep 18, 2019 6:15 pm America/New_York
Answers: 1
Been thanked: 1 time

Installation Issue with Seadas 7.3.2 and processing programs.

by OB.DAAC - SeanBailey » Tue Feb 14, 2017 10:37 am America/New_York

The problem is with gnutls.  By default, Git is compiled against that, but that has issues with newer SSL certificates.
you will need a version of Git compiled against the openssl library.  One of our sysadmins described the process:

https://oceancolor.gsfc.nasa.gov/forum/oceancolor/topic_show.pl?pid=27714

Sean

gnwiii
Posts: 669
Joined: Fri Jan 29, 2021 5:51 pm America/New_York
Answers: 2

Installation Issue with Seadas 7.3.2 and processing programs.

by gnwiii » Tue Feb 14, 2017 10:37 am America/New_York

The "gnutls_handshake() failed: Handshake failed" looks like the old version of git is being used.   You may need adjust the PATH variable to ensure that the new version is used, and you may want to uninstall the old git version.

Your $OCSSWROOT/run/data/common/.git/config seems to be missing the current branch:

[branch "v7.3"]
        remote = origin
        merge = refs/heads/v7.3


You need to add "-b v7.3" to the install_ocssw.py command line.

bertrand_saulquin
Posts: 5
Joined: Mon Feb 13, 2017 9:47 am America/New_York

Installation Issue with Seadas 7.3.2 and processing programs.

by bertrand_saulquin » Fri Feb 17, 2017 3:53 am America/New_York

Dear,

i managed to download the bundle files and install them (i.e. fix the git issue on my Ubuntu).  So now seadas 7.3 and OCSSW are installed.

I setup the following variables as:
export JAVA_HOME=/usr/lib/jvm/java-8-oracle/jre
export PATH=$JAVA_HOME/bin:$PATH
;to get the good version of GIT
export PATH=~/usr/local/bin:$PATH
export SEADAS=xx
export PATH=$SEADAS/bin:$PATH
export OCSSWROOT=$SEADAS/ocssw
source $OCSSWROOT/OCSSW_bash.env

Seadas is launching correctly, nevertheless when i try update (OCSSW/Update OC processors menu) i got this error:

"ocssw installation script failed to download check seadas.ocssw.root in seadas.config".

Is seadas.home of seadas.config different from $SEADAS ?

An idea of the cause of the problem?

Thks

gnwiii
Posts: 669
Joined: Fri Jan 29, 2021 5:51 pm America/New_York
Answers: 2

Installation Issue with Seadas 7.3.2 and processing programs.

by gnwiii » Fri Feb 17, 2017 7:49 am America/New_York

You asked "Is seadas.home of seadas.config different from $SEADAS ?".   The answer is that they should generally be the same, e.g., SEADAS and seadas.home are both set to <SeaDAS_Install_Dir>.  The GUI gets the value for seadas.home from <SeaDAS_Install_Dir>/.install4j/i4jparams.conf.  The message suggests a problem with seadas.ocssw.root, which is set in $SEADAS/config/seadas.config. You can view the GUI's  settings for seadas.home and seadas.ocssw.root (Menu: SeaDAS/About SeaDAS then click on "System Info...").

Post Reply