Page 1 of 1 is failed for Landsat8 OLI

Posted: Thu Jun 15, 2017 11:25 pm America/New_York
by zhigang
Dear everyone,
       A granule of OLI data was downloaded from USGS (new website) named :LC08_L1TP_119038_20170527_20170527_01_RT_MTL.txt. However, I can't download the ancillary files by GUI and The message was:
ERROR: For LC08_L1TP_119038_20170527_20170527_01_RT_MTL.txt could not determine:  start time, start date, stoptime, stop date. Exiting.
l1info reported the following error:
    -E- /data5/swdev/seadas/build/src/liboli/get_oli_nom_angles.c line 37: Initializing the metadata file /home/rslakes/optics/source/taihu/LC08_L1TP_119038_20170527_20170527_01_RT/LC08_L1TP_119038_20170527_20170527_01_RT_MTL.txt.

The filename from new USGS website was different from old website, I guessed that the script can't identify the date. I have updated the processors.
What I should do, could someone give me some suggestions?

zhigang is failed for Landsat8 OLI

Posted: Mon Jun 19, 2017 5:47 pm America/New_York
by melliott

Checking the USGS Earth Explorer site, I didn't find the file you mentioned, but did get one processed more recently named LC08_L1TP_119038_20170527_20170615_01_T1_MTL.txt. After downloading it, I ran and it worked. So my response is the dreaded "Worked on my machine."

Did you get the file from Earth Explorer? Is the program able to identify it? Does using its "-t" option provide the start and end times?

That said, our software does not yet support the new format. No date has been set for when that will happen.