Page 1 of 1

after upgrade ubuntu up to 18.0 the utility gpt.sh doesn't work

Posted: Fri Aug 24, 2018 4:16 am America/New_York
by slava.suslin
Good day,

after upgrade Ubuntu up to 18.0  the utility gpt.sh doesn't work

before upgrade Ubuntu (16....) all're ok.

/home/slava/seadas-7.4/bin/gpt.sh Write -Ssource=A2018009104000.L2_LAC_OC.x.nc -PformatName=CSV -Pfile="test.oc.csv"

now current output is
===java.lang.IllegalArgumentException: org.geotools.styling.StyleFactory is not an ImageIO SPI class
  at java.desktop/javax.imageio.spi.ServiceRegistry.checkClassAllowed(ServiceRegistry.java:722)
  at java.desktop/javax.imageio.spi.ServiceRegistry.<init>(ServiceRegistry.java:117)
  at org.geotools.factory.FactoryRegistry.<init>(FactoryRegistry.java:154)
  at org.geotools.factory.FactoryCreator.<init>(FactoryCreator.java:90)
  at org.geotools.factory.CommonFactoryFinder.getServiceRegistry(CommonFactoryFinder.java:78)
  at org.geotools.factory.CommonFactoryFinder.lookup(CommonFactoryFinder.java:315)
  at org.geotools.factory.CommonFactoryFinder.getFilterFactory(CommonFactoryFinder.java:286)
  at org.geotools.feature.AttributeTypeBuilder.<init>(AttributeTypeBuilder.java:192)
  at org.geotools.feature.AttributeTypeBuilder.<init>(AttributeTypeBuilder.java:199)
  at org.geotools.feature.simple.SimpleFeatureTypeBuilder.<init>(SimpleFeatureTypeBuilder.java:189)
  at org.geotools.feature.simple.SimpleFeatureTypeBuilder.<init>(SimpleFeatureTypeBuilder.java:179)
  at org.esa.beam.framework.datamodel.Placemark.createPointFeatureType(Placemark.java:428)
  at org.esa.beam.framework.datamodel.Placemark.createPinFeatureType(Placemark.java:412)
  at org.esa.beam.framework.datamodel.Product.createPinGroup(Product.java:1262)
  at org.esa.beam.framework.datamodel.Product.<init>(Product.java:252)
  at org.esa.beam.framework.datamodel.Product.<init>(Product.java:221)
  at org.esa.beam.framework.datamodel.Product.<init>(Product.java:206)
  at gov.nasa.gsfc.seadas.dataio.L2FileReader.createProduct(L2FileReader.java:100)
  at gov.nasa.gsfc.seadas.dataio.SeadasProductReader.readProductNodesImpl(SeadasProductReader.java:170)
  at org.esa.beam.framework.dataio.AbstractProductReader.readProductNodes(AbstractProductReader.java:173)
  at org.esa.beam.framework.gpf.main.DefaultCommandLineContext.readProduct(DefaultCommandLineContext.java:54)
  at org.esa.beam.framework.gpf.main.CommandLineTool.readProduct(CommandLineTool.java:495)
  at org.esa.beam.framework.gpf.main.CommandLineTool.addProduct(CommandLineTool.java:435)
  at org.esa.beam.framework.gpf.main.CommandLineTool.getSourceProductMap(CommandLineTool.java:422)
  at org.esa.beam.framework.gpf.main.CommandLineTool.runOperator(CommandLineTool.java:257)
  at org.esa.beam.framework.gpf.main.CommandLineTool.runGraphOrOperator(CommandLineTool.java:246)
  at org.esa.beam.framework.gpf.main.CommandLineTool.run(CommandLineTool.java:150)
  at org.esa.beam.framework.gpf.main.CommandLineTool.run(CommandLineTool.java:122)
  at org.esa.beam.framework.gpf.main.GPT.run(GPT.java:54)
  at org.esa.beam.framework.gpf.main.GPT.main(GPT.java:34)
  at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
  at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
  at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
  at java.base/java.lang.reflect.Method.invoke(Method.java:564)
  at com.bc.ceres.launcher.Launcher.launch(Launcher.java:154)
  at com.bc.ceres.launcher.Launcher.main(Launcher.java:56)

Error: org.geotools.styling.StyleFactory is not an ImageIO SPI class
===

What must I do? Return to old OC version?

The output is the same after the installation of seadas 7.5.1 ..

Thank you,
slava

after upgrade ubuntu up to 18.0 the utility gpt.sh doesn't work

Posted: Fri Aug 24, 2018 9:05 am America/New_York
by slava.suslin
Sorry,

I send my question (see top)  to BEAM forum

thank You,
slava

after upgrade ubuntu up to 18.0 the utility gpt.sh doesn't work

Posted: Fri Aug 24, 2018 12:01 pm America/New_York
by OB.DAAC - SeanBailey
Slava,

Make sure you're using Java version 8.  We're aware of some issues with SeaDAS using higher versions of java, this *might* be one of them.

Sean

after upgrade ubuntu up to 18.0 the utility gpt.sh doesn't work

Posted: Sun Aug 26, 2018 11:17 am America/New_York
by slava.suslin
Sean,

thank You for your replay

I check java version in my PC
results:
--
slava@anton:~$ java -version
openjdk version "10.0.2" 2018-07-17
OpenJDK Runtime Environment (build 10.0.2+13-Ubuntu-1ubuntuxx.xxx.xx.xx)
OpenJDK 64-Bit Server VM (build 10.0.2+13-Ubuntu-1ubuntuxx.xxx.xx.xx, mixed mode)
--
Does this mean that I must remove this version (10) of Java and install its 8 version?

Now i have no reply from BAEM forum.

thank you,
slava

after upgrade ubuntu up to 18.0 the utility gpt.sh doesn't work

Posted: Mon Aug 27, 2018 8:39 am America/New_York
by OB.DAAC - SeanBailey
Slava,

You can have more than one version installed at the same time.
You also probably want to install the Oracle version, as OpenJDK does not play well with SeaDAS.
You can even have a local installation of Java (i.e. not system wide) and point the shell rrom which you
launch SeaDAS at that version.

Sean

after upgrade ubuntu up to 18.0 the utility gpt.sh doesn't work

Posted: Mon Aug 27, 2018 11:05 am America/New_York
by slava.suslin
Sean,

thank You.
I'll try it.

slava

after upgrade ubuntu up to 18.0 the utility gpt.sh doesn't work

Posted: Thu Aug 30, 2018 9:44 am America/New_York
by slava.suslin
Sean,

it's ok. i do it. this step works.

thank You,
slava