Error updating LUTS

Use this Forum to find information on, or ask a question about, NASA Earth Science data.
Post Reply
ana_dogliotti
Posts: 28
Joined: Mon Sep 12, 2005 1:16 pm America/New_York

Error updating LUTS

by ana_dogliotti » Mon Jul 15, 2019 6:47 pm America/New_York

Hello,

I've just updated SeaDAS to the latest version 7.5.3. But when I try to instal the processors for the different sensors I always get to this problem at the last step regardñess the sensor. I'm copying 2 examples

Installing scripts (11 of 12)
Python version acceptable
Installing viirsnpp-luts (12 of 12)
Traceback (most recent call last):
  File "/home/tele/seadas-7.5/ocssw/scripts/update_luts.py", line 66, in <module>
    luts.get_luts()
  File "/home/tele/seadas-7.5/ocssw/scripts/modules/LutUtils.py", line 132, in get_luts
    regex='^((?!\d+).)*' + suffix, check_times=True)
  File "/home/tele/seadas-7.5/ocssw/scripts/modules/JsonUtils.py", line 272, in download_allfiles
    all_links = self.get_links(url, regex=regex)
  File "/home/tele/seadas-7.5/ocssw/scripts/modules/JsonUtils.py", line 238, in get_links
    content = response.read()
AttributeError: 'NoneType' object has no attribute 'read'
Error - Could not install luts for viirsn

Installing scripts (11 of 12)
Python version acceptable
Installing aqua-luts (12 of 12)
Traceback (most recent call last):
  File "/home/tele/seadas-7.5/ocssw/scripts/update_luts.py", line 66, in <module>
    luts.get_luts()
  File "/home/tele/seadas-7.5/ocssw/scripts/modules/LutUtils.py", line 132, in get_luts
    regex='^((?!\d+).)*' + suffix, check_times=True)
  File "/home/tele/seadas-7.5/ocssw/scripts/modules/JsonUtils.py", line 272, in download_allfiles
    all_links = self.get_links(url, regex=regex)
  File "/home/tele/seadas-7.5/ocssw/scripts/modules/JsonUtils.py", line 238, in get_links
    content = response.read()
AttributeError: 'NoneType' object has no attribute 'read'
Error - Could not install luts for aqua

Any idea?
Best

Ana

Tags:

gnwiii
Posts: 670
Joined: Fri Jan 29, 2021 5:51 pm America/New_York
Answers: 2

Error updating LUTS

by gnwiii » Mon Jul 15, 2019 8:17 pm America/New_York

It is not unusual to have problems with update_luts.py when running install_ocssw.py.   The latter uses several different tools (curl or wget and git) to download the software and data files.   The python script update_luts.py is less robust than the other tools and may fail when the others work.  Sometimes the problems are just transient internet glitches (which I think you have encountered in the past). 

Since installing the LUT's is the last step in the installation, you don't need to keep trying install_ocssw.py.   You can just run update_luts.py in a terminal to complete the installation.  You may need to do this several times.   There are several groups of files to be downloaded.  Adding the -v (verbose output) option may show which group is having problems.

ana_dogliotti
Posts: 28
Joined: Mon Sep 12, 2005 1:16 pm America/New_York

Error updating LUTS

by ana_dogliotti » Tue Jul 16, 2019 6:49 am America/New_York

Thanks for the clear explanation! I'll keep trying!
Best

Ana

ana_dogliotti
Posts: 28
Joined: Mon Sep 12, 2005 1:16 pm America/New_York

Error updating LUTS

by ana_dogliotti » Thu Jul 18, 2019 6:22 am America/New_York

Hello,

I've been trying these days an could not get the LUTS for even one sensor! I've tried at different times of the day, night, midnight... and nothing. I have good internet connection... Is there other way to do this? At the befinning I downloaded them offline, but then they needed to be updated and I was back to the same problem.
Is there a way to get round this?
Thanks

Ana

OB.DAAC - SeanBailey
User Services
User Services
Posts: 1315
Joined: Wed Sep 18, 2019 6:15 pm America/New_York
Answers: 1
Been thanked: 1 time

Error updating LUTS

by OB.DAAC - SeanBailey » Thu Jul 18, 2019 9:16 am America/New_York

If you are having issues using the update_luts.py script, you could manually pull the files from: https://oceandata.sci.gsfc.nasa.gov/Ancillary/LUTs/

Sean

Post Reply