Page 1 of 1 reprojection issue

Posted: Thu Jul 30, 2020 7:13 am America/New_York
by junzhao
Hi there,
I tried to use the gpt tool for reprojection and followed the cookbook. The executed command was reproj.xml -p reproj.par -Ssource=./tmp/ -t

But I got the following error:
java.lang.IllegalArgumentException: Variable size in bytes 4922639944996268 may not exceed 4294967292
        at ucar.nc2.NetcdfFileWriteable.addVariable(
        at ucar.nc2.NetcdfFileWriteable.addVariable(
        at org.esa.beam.dataio.netcdf.NetCdfWriteProfile.writeProduct(
        at org.esa.beam.dataio.netcdf.DefaultNetCdfWriter.writeProductNodesImpl(
        at org.esa.beam.framework.dataio.AbstractProductWriter.writeProductNodes(
        at org.esa.beam.gpf.operators.standard.WriteOp.initialize(
        at org.esa.beam.framework.gpf.internal.OperatorContext.initializeOperator(
        at org.esa.beam.framework.gpf.internal.OperatorContext.getTargetProduct(
        at org.esa.beam.framework.gpf.Operator.getTargetProduct(
        at org.esa.beam.framework.gpf.graph.NodeContext.initTargetProduct(
        at org.esa.beam.framework.gpf.graph.GraphContext.initNodeContext(
        at org.esa.beam.framework.gpf.graph.GraphContext.initOutput(
        at org.esa.beam.framework.gpf.graph.GraphContext.<init>(
        at org.esa.beam.framework.gpf.graph.GraphContext.<init>(
        at org.esa.beam.framework.gpf.graph.GraphProcessor.executeGraph(
        at org.esa.beam.framework.gpf.main.DefaultCommandLineContext.executeGraph(
        at org.esa.beam.framework.gpf.main.CommandLineTool.executeGraph(
        at org.esa.beam.framework.gpf.main.CommandLineTool.runGraph(
        at org.esa.beam.framework.gpf.main.CommandLineTool.runGraphOrOperator(
        at org.esa.beam.framework.gpf.main.GPT.main(
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(
        at java.lang.reflect.Method.invoke(
        at com.bc.ceres.launcher.Launcher.launch(
        at com.bc.ceres.launcher.Launcher.main(

Error: Variable size in bytes 4922639944996268 may not exceed 4294967292

The xml and par files are attached.

But if lines 33 and 34 in the xml file are removed, everything works well. The two lines are for setting pixel size.

Any suggestions are greatly appreciated.

attachment 1

attachment 2 reprojection issue

Posted: Thu Jul 30, 2020 9:13 am America/New_York
by OB SeaDAS - dshea
Your XML file looks like you are asking for 9 millimeter wide pixels.  That would be too many pixels, which you do not have enough memory to store.  You are trying to allocate about 5 PetaBytes of memory.

don reprojection issue

Posted: Fri Jul 31, 2020 10:56 am America/New_York
by junzhao
Dear Don,

Thanks for your prompt reply. I changed the pixel size to 250. The code works now. But there was another issue.

My study area covers an area defined by 21.5-23 N and 113-115 E. The l1mapgen command generated a RGB map with a size of 220x165 (1km resolution). However, the code using the gpt tool mentioned in my previous post resulted in product maps with a size of 224x168 for Terra, Aqua, and VIIRS-SNPP and of 222x168 for VIIRS-JPSS1. The size of the product maps should be the same as that of the RGB map, i.e. 220x165.

BTW, what I did was (1) reprojection and (2) subset using the gpt tool.

Any solution?

Jun reprojection issue

Posted: Wed Aug 05, 2020 2:26 pm America/New_York
by zhigang
Hi Jun,

You may try to use the Mosaic tool via, it is able to generate images with the same sizes. A GPT Cookbook including Mosaic can be found in SeaDAS help document.