seadas update luts problem

Please enter here to ask a question about any NASA Science related topics!
Post Reply
jay_cable
Posts: 11
Joined: Wed Feb 01, 2017 4:22 pm America/New_York

seadas update luts problem

by jay_cable » Tue Sep 21, 2021 2:40 pm America/New_York

Starting this morning I am having issues with update_luts failing:

[processing@nrt-seadas-prod-0001 ~]$ update_luts --version
update_luts 2.0

[processing@nrt-seadas-prod-0001 ~]$ update_luts -vd aqua

Downloading files into /opt/modis/ocssw/var/common
DEBUG:Converted retries value: 5 -> Retry(total=5, connect=None, read=None, redirect=None, status=None)
OBPG session started
DEBUG:Starting new HTTPS connection (1): oceandata.sci.gsfc.nasa.gov:443
DEBUG:https://oceandata.sci.gsfc.nasa.gov:443 "GET /Ancillary/LUTs/common/?format=json HTTP/1.1" 200 359
DEBUG:https://oceandata.sci.gsfc.nasa.gov:443 "GET /Ancillary/LUTs/common/polar_wander.ascii HTTP/1.1" 304 0
Error downloading /opt/modis/ocssw/var/common/polar_wander.ascii
+ polar_wander.ascii

The url looks fine:
[processing@nrt-seadas-prod-0001 ~]$ curl -s https://oceandata.sci.gsfc.nasa.gov/Anc ... nder.ascii | head --lines=2
92 1 1 48622.00 I 0.182987 0.000672 0.168775 0.000345 I-0.1251659 0.0000207 1.8335 0.0201 I -0.086 0.202 0.130 0.165 .182400 .167900 -.1253000 0.129 -0.653
92 1 2 48623.00 I 0.180614 0.000672 0.166776 0.000345 I-0.1269551 0.0000203 1.7556 0.0144 I -0.027 0.202 0.128 0.165 .180300 .165900 -.1270800 0.155 -0.575

OB.DAAC - amscott
User Services
User Services
Posts: 96
Joined: Mon Jun 22, 2020 5:24 pm America/New_York
Answers: 1

Re: seadas update luts problem

by OB.DAAC - amscott » Tue Sep 21, 2021 5:24 pm America/New_York

Should be fixed. Please try and let us know if you have continued issues.
--
Alicia

jay_cable
Posts: 11
Joined: Wed Feb 01, 2017 4:22 pm America/New_York

Re: seadas update luts problem

by jay_cable » Tue Sep 21, 2021 7:50 pm America/New_York

I am getting the same behavior.


[processing@nrt-seadas-prod-0001 ~]$ update_luts -vd terra
Downloading files into /opt/modis/ocssw/var/common
DEBUG:Converted retries value: 5 -> Retry(total=5, connect=None, read=None, redirect=None, status=None)
OBPG session started
DEBUG:Starting new HTTPS connection (1): oceandata.sci.gsfc.nasa.gov:443
DEBUG:https://oceandata.sci.gsfc.nasa.gov:443 "GET /Ancillary/LUTs/common/?format=json HTTP/1.1" 200 359
DEBUG:https://oceandata.sci.gsfc.nasa.gov:443 "GET /Ancillary/LUTs/common/polar_wander.ascii HTTP/1.1" 304 0
Error downloading /opt/modis/ocssw/var/common/polar_wander.ascii
+ polar_wander.ascii

OB.DAAC - SeanBailey
User Services
User Services
Posts: 1219
Joined: Wed Sep 18, 2019 6:15 pm America/New_York
Answers: 1

Re: seadas update luts problem

by OB.DAAC - SeanBailey » Wed Sep 22, 2021 7:33 am America/New_York

Jay,
This is a fun one...if you run update_luts with -vv you should see that the error is a status 304, which isn't really an error (server is just telling the client that the resource hasn't changed). While not an error, it seems to be tripping up the error catching in the script.

If you delete $OCVARROOT/common/polar_wander.ascii and rerun update_luts it should work.

We'll fix the code (since the change to the server that resulted in this condition is likely to stick around for a while).

Sean

Post Reply