Page 1 of 1

Install Wget on macOS

Posted: Tue Jun 28, 2022 12:26 pm America/New_York
by yang16

I failed to install Wget on my PC with macOS system. At first, I downloaded the latest version (Wget2-latest.tar.gz) of Wget from this link:;O=A
Then I complied it using the following commands:
$ gunzip < wget2-latest.tar.gz | tar -xv
$ cd wget2-2.0.1
$ ./configure
$ make
# make install
When I ran "./configure", I got warnings as below:
configure: WARNING: *** WolfSSL was not found.
configure: error: *** No SSL/TLS library not found.
Then when I ran "make", I got error as below:
There seems to be no Makefile in this directory.
You must run ./configure before running '/Library/Developer/CommandLineTools/usr/bin/make'.
make: *** [abort-due-to-no-makefile] Error 1

Do you know how to fix this issue?

Thank you in advance.

Re: Install Wget on macOS

Posted: Wed Jun 29, 2022 2:47 pm America/New_York
by OB.DAAC - amscott

Re: Install Wget on macOS

Posted: Wed Jun 29, 2022 7:41 pm America/New_York
by yang16
Thank you for your reply. I tried it, but got error as below:
curl: (7) Failed to connect to port 443: Connection refused
Actually, I got this error when I tried to install Homebrew before and I could not fix this error.
I may find other ways to download the data.