Page 1 of 1

Unable to establish SSL connection.

Posted: Thu Feb 16, 2023 6:34 pm America/New_York
by paunaranjo
I've been trying to use wget to download MERRA data from this link:[0:0][0:60][0:575],time,lat[0:60],lon[0:575].
But i keep getting this error: Unable to establish SSL connection. I tried downloading with python "requests" and "pydap" but I get the 401 Unauthorized Error and webob.exc.HTTPError: 404 Not Found, respectively.

(the reason why i don't download it directly from the URL is that i have a .txt with +100 urls to download and I'm trying to download one as a test, I've tried with other URL's but i get the same errors)

Here's my code
C:\>wget --load-cookies C:\.urs_cookies --save-cookies C:\.urs_cookies --auth-no-challenge=on --keep-session-cookies --user=paunaranjo --ask-password[0:0][0:60][0:575],time,lat[0:60],lon[0:575]
Password for user 'paunaranjo':

--2023-02-16 20:18:41--[0:0][0:60][0:575],time,lat[0:60],lon[0:575]
Resolving (
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: [following]
--2023-02-16 20:18:42--
Resolving (
Connecting to (||:443... connected.
Unable to establish SSL connection.

Re: Unable to establish SSL connection.

Posted: Fri Feb 17, 2023 9:40 am America/New_York
by GES DISC - mgreene
User paunaranjo ,

Please perform the following,
1. Check if you can download from Web Browser
2. Execute wget --load-cookies C:\.urs_cookies --save-cookies C:\.urs_cookies --auth-no-challenge=on --keep-session-cookies --user=paunaranjo --ask-password -v
3. Check version of wget, 'wget -V', upgrade to at least 1.19.5

Also I see that you provided your Earthdata Login password, for security purposes please go to to make the change.