max number of PACE products processed by l2bin

Use this Forum to find information on, or ask a question about, NASA Earth Science data.
Post Reply
Posts: 29
Joined: Wed May 26, 2010 4:19 pm America/New_York
Answers: 0

max number of PACE products processed by l2bin

by monger » Tue Apr 04, 2023 8:06 am America/New_York

Hi-- I have been working on processing PACE-OCI Simulated Level-2 data to Level-3. I am running with SeaDAS 8.3.0 on Mac OS Ventura (13.2.1). I am processing L2 > l2bin > l3bin > l3mapgen > L3. When I run things with PACE Rrs_Bands[0:128] or less (given as a single comma delimited string), things work fine. When I run things with Rrs_Bands[0:129] or greater it does not run correctly.

Here are some bits of added info regarding that might help diagnosis of the problem. It seems to run through the l2bin function in both cases without throwing any error (that I can see). When the output from l2bin is subsequently processed with l3bin it prints done! when the processing is completed correctly (i.e., for the case of 129 initial products or less) and seems to go through the processing two by row, but does not print done! at the end when processing more than 129 products. In the case where l3bin ends by printing done!, l3mapgen works fine and I get my mapped products. When l3bin does not print done!, then the subsequent processing of its output but l3mapgen throws the following error and no mapped product is produced:

"Did not find a valid sensor ID - using OCRVC as the sensor ID.
Loading default parameters from /Applications/seadas-8.3.0/ocssw/share/ocrvc/l3mapgen_defaults.par
Binning Scheme metadata not found"

Thanks for any help/comments here.


OB.DAAC - SeanBailey
User Services
User Services
Posts: 1485
Joined: Wed Sep 18, 2019 6:15 pm America/New_York
Answers: 1
Been thanked: 5 times

Re: max number of PACE products processed by l2bin

by OB.DAAC - SeanBailey » Wed Apr 05, 2023 3:20 pm America/New_York

I don't have an answer for you except to say that getting the binner to be happy with the insane number of products that OCI will produce is actively being worked :). I do know that there was a memory issue that was identified and resolved, perhaps that was affecting your processing. This and other recent updates to the binner code to support the 3D L2 products we will be generating from OCI were pushed as V2023.1 yesterday. Maybe it will be the fix you need? If not, let us know :)


Post Reply