Page 1 of 1

l2gen mission directory not found

Posted: Thu Jun 29, 2023 4:58 am America/New_York
by nathra
Hello! I am running SeaDas on Windows, and used the WSL method to do so. I was able to install the OCSSW processors manually, and was recently able to open l2gen. However, I am now running into an issue. When I select my ifile, LC08_L2SP_011031_20150922_20200908_02_T1_MTL.txt, it gives me this warning:

# WARNING!!! Mission directory 'C:\home\nathra\ocssw\share\oli\l8' does not exist

I believe this is because the path is different due to me using WSL, the actual path is
\\wsl.localhost\Ubuntu\home\nathra\ocssw\share\oli\l8

However, I opened up the ifile and nowhere in it do I see a reference to a mission directory or any way I could change the path. Any ideas?

Thanks!

Re: l2gen mission directory not found

Posted: Thu Jun 29, 2023 2:08 pm America/New_York
by OB SeaDAS - xuanyang02
LC08_L2SP_011031_20150922_20200908_02_T1_MTL.txt is an L2 file, l2gen needs an L1 file as input, looks like this--
LC08_L1TP_011031_20230523_20230602_02_T1_MTL.txt

SeaDAS uses obpg_file_type to find the mission of the file, and then look for the mission directory accordingly.

You might want to give Docker a try, it's a lot easier to set up -- https://seadas.gsfc.nasa.gov/client_server/

Re: l2gen mission directory not found

Posted: Wed Jul 05, 2023 9:31 pm America/New_York
by nathra
Hello,

Thanks for the advice, I will give Docker Desktop a try (I did try it before but ran into an issue and abandoned it once I got WSL to work). In the meantime, I tried using the L1 file: the ifile was called LC08_L1TP_011031_20151211_20200908_02_T1_MTL.txt
but I am unfortunately getting the same error. Any insight is appreciated but I'll try to get Docker to work as well.

Thanks,
Nathra

Re: l2gen mission directory not found

Posted: Thu Jul 06, 2023 5:08 am America/New_York
by nathra
Hello,

I just tried setting up Docker Desktop - I was able to run the server in the PowerShell, yet I am running into the issue that whenever I try to edit the seadas.properties file to set the location to docker, whenever I try to open l2gen in SeaDas, it switches the location back to virtualMachine. Any suggestions?

Thanks,
Nathra

Re: l2gen mission directory not found

Posted: Thu Jul 06, 2023 10:47 am America/New_York
by OB SeaDAS - xuanyang02
You might need to close SeaDAS, delete .seadas8 directory and restart SeaDAS. Edit seadas.properties again.

When you open l2gen, it'll open SeaDAS Processors Location window, and it's ok to choose Virtual Machine for "OCSSW Location".

Here is the link to the webinar "Learn How to Use SeaDAS with Docker for Ocean Color Data Analysis" --https://www.youtube.com/watch?v=3tLRh8rQz2A. The docker part starts at 28:30

Re: l2gen mission directory not found

Posted: Thu Jul 13, 2023 5:22 am America/New_York
by nathra
Thank you for your help! I was able to open l2gen.

However, I am having an issue with the products. When I select chlor a as one of the products, I get an error, these are the last few lines:

Processing scan # 0 (1 of 7931) after 5 seconds
Aerosol selection bands 865 and 1609
NIR correction enabled.
chl_abi is not compatible with this sensor

When I don't select chlor a, it runs. Do you have any suggestions for how to proceed?

Thanks,
Nathra

Re: l2gen mission directory not found

Posted: Thu Jul 13, 2023 10:00 am America/New_York
by OB SeaDAS - xuanyang02
What product name did you use for "chlor_a"? The default products for Landsat 8 are "Kd_490 Rrs_vvv angstrom aot_865 chlor_a". Make sure it's "chlor_a" with an underscore.

Can you take a screenshot of your l2gen GUI "Products" tab, and post it here?

Can you also do SeaDAS-Toolbox -> Software & System Info, and post the result here?