seadas install: java: Bad CPU type in executable

Use this Forum to find information on, or ask a question about, NASA Earth Science data.
Post Reply
Posts: 49
Joined: Thu Jan 24, 2008 1:33 pm America/New_York
Answers: 0
Has thanked: 1 time
Been thanked: 1 time

seadas install: java: Bad CPU type in executable

by treble » Tue Feb 27, 2024 1:06 pm America/New_York

I am helping someone install SeaDAS on a MacBook M2. We are getting the following error:

Code: Select all

bash-3.2$ sh 
Verifying archive integrity...  100%   MD5 checksums are OK. All good.
Uncompressing SeaDAS by Ocean Ecology Lab  100%  
./ line 2: jdk-11.0.19+7/Contents/Home/bin/java: Bad CPU type in executable
I have not seen this error in all my installs. Also tried downloading java/jdk from, which didn't change, and then with brew. But I think the installer is using the 'built-in' version of the installer itself?

I also copied a version of file that I had on my Mac to install SeaDAS to the MacBook, but got the same error....

Does anyone know what is going on?


OB SeaDAS - xuanyang02
Subject Matter Expert
Subject Matter Expert
Posts: 664
Joined: Tue Feb 09, 2021 5:42 pm America/New_York
Answers: 1
Been thanked: 2 times

Re: seadas install: java: Bad CPU type in executable

by OB SeaDAS - xuanyang02 » Fri Apr 12, 2024 9:45 am America/New_York

Sorry for the delayed reply. Now SeaDAS 9 is just released, could you please try docker 2.0 with it, see if the issue persists -

Post Reply