Page 1 of 1

OCCSW binary compatibility in Linux

Posted: Mon Apr 15, 2024 1:45 pm America/New_York
by oo_processing
Dear Support,

In the past, the OCCSW binary version can run on our cluster, so it's not hard to install. But, the recent T2024.16 requires glibc >= 2.37 on the system level which I'm unable to upgrade. I have to build the program locally, and it was not straightforward. I did retry too many times and fix all sorts of issues before got the program finally.
I wonder if possible you guys can make the binary version with a lower requirement (at least for the V tag), I think many of us are still running old Linux machines.

Thanks
Yuyuan

Re: OCCSW binary compatibility in Linux

Posted: Mon Jun 03, 2024 12:56 pm America/New_York
by treble
Me too :-). Our cluster is running CenOS 7, it's old, but they are not planning to upgrade soon...

I tried to compile from scratch but that failed. See some of my earlier posts.